Sandisk SSD Plus shows 0 mb

first thing i intall the ssd 1tb into pc (msi military class 4 h81m-p33, 4gb ram hyperX) i have also primary boot hdd which is 500gb, i was wanting to use the ssd as primary boot windows. I install software in hdd  easybcd, to install windows without cd or usb, i format my primary partition  which in hdd c: so i make a new partition which is 5gb for the easybcd boot manager. I install the Windows ROG x64bit in SSD 1tb. Its good going its fast i used it few weeks until i run assessment my pc shuts off and i see bluescreen of death. When i restarted missing operating system. When i use my another hdd 1tb as primary boot, i plug the Sandisk ssd plus it shows 0mb, It shows Milpitas ssd, i plug also the ssd in external enclosure it also shows 0mb, Please help me i cant use my ssd anymore

it sounds like the ssd is bad and will need to be replaced. contact sandisk support to check the warranty status. 

Hello, it happened to me too.What happened if they changed the ssd???Or they managed to fix it???

After 1.5 month of use SSD just died. Halted on power on and keeps rebooting after restart.
Bios-Windows logo-rebut, Bios-Window logo-rebut and so on.
It was a system disc. Now all files completely gone. It doesn’t starts in PC, it doesn’t starts in SSD enclosure,
Windows cannot repair errors on it, Windows can’t format it and install new copy.

Now SSD shows 16kb! of storage and has a strange name “Sandisc Milpitas SSD”.

Showing 16K?  This is the same issue I am having but I was using Mac OS X.  My 2 drives lasted a week.

I now have $400 worth of coasters.

Jeff

Oh and SanDisk refused to RMA them because I installed them in a Mac mini Server.  They said “because it was used in a server environment the warranty is void”

Nice.

Jeff

I think maybe you buy a fake copy Sandisk. I see this video of example https://www.youtube.com/watch?v=DHdoL08HnjE. The Dashboard no detect the drive

Mine isn’t fake. I’m getting this message if i scan the verify code.

“Security code query:
Security code: **************************
The security code you entered is correct, but it has been queried. You can call 400-677-8830 for manual query. We can provide the first query time and query method.”

I bet they will find another excuse for my story, as mine wasn’t in server. It was in a typical home PC.

Hello everyone.Did anyone find a solution to this problem? Who has a warranty  will it replace with a new ssd?

Mine was replaced directly by Sandisk. New, unopened SSD.