SanDisk SSD Dashboard corrupted my BIOS..!!

After a recent firmware upgrade on my SSD Ultra in my Samsung Laptop NP300E,

my BIOS is now stuck with the ‘Sandisk SSD Dashboard’ as the only Boot option.

Image00001.jpg I have tried Resetting Bios to factory defaults and it’s still the same.

I have removed the SSD and DVD drive from the laptop and it’s still the same.

I installed a mechanical hard drive and it’s still the same.

I have swithed between UEFI/BIOS as well as IDE/AHCI options and it’s still the same.

I also removed the BIOS battery (CR2032) for over 12 hours and it’s still the same.

I simply can’t get any other boot options in the BIOS and the laptop does not boot.

How is this possible???

I wish I never attempted to update the firmware if I knew it was gonna corrupt my BIOS like this.

P.S. The firmware upgraded sucessfully as I can use my SSD on a different PC, but my laptop is screwed… 


Can you contact our support center so we can securely obtain your contact information ? 

You can let our support team know that you have posted this question in our forum and ask them to escalate to L3 and I can contact you directly