SanDisk SecureAccess 2.0

SanDisk SecureAccess v2.0 is a fast, simple way to store and protect critical and sensitive files on any SanDisk USB flash drive.

Access to your private vault is protected by a personal password, and your files are automatically encrypted - so even if you share your SanDisk® USB flash drive or it becomes lost or stolen, access to your files are safe.

SecureAccess v2.0 features
- Quicker start-up
- Improved password settings
- Ability to edit your documents stored in vault
- Encrypted Backup and Restore data stored in vault
- Optional File Shredder (deletion) from source after transfer to vault
- Automatic logout time-out setting

Migrate/Upgrade from SecureAccess v1.0 to v2.0 for Windows
Migrate/Upgrade from SecureAccess v1.0 to v2.0 for Mac

Download SecureAccess:
Download for PC (7MB)
Download for Mac (14MB)

Quick Start Guide:
Download Quick Start Guide

Languages Supported
English, FrenchGerman, SpanishItalianPortuguese (Brazilian), Simplified ChineseTraditional Chinese, and Korean

System Requirements

  • Microsoft Windows® 8, Microsoft Windows® 7, Windows Vista®, Windows XP
  • Mac OS® X 10.5+
1 Like

I followed the instructions provided by SanDisk for the Mac and lost my data!  Do not upgrade until they fix the error which doesn’t allow larger files to be copied and transferred.  Found that out from a level one tech there is an issue with large files.  I copied and dragged my backed up files from my desktop into the locker and the size of the transfer or maybe one of my larger files crashed the transfer and all my files were lost except for the first couple of files that transferred.  You will get an error message saying the disk is full when you actually have gigabytes of capacity.

If you do decide to upgrade make multiple copies of your file folders on your desktop or wait to delete version 1 and My Vault until you know the files have been successfully transferred.  That way if it crashes Finder on a Mac you still have a backup of the files.

I’m hoping there is way to reinstall v1 and My Vault to recover my files!  Please advise.  I tried moving them from trash back to the disk but that didn’t work.

1 Like

If you followed the instructions listed for Mac in this FAQ it instructs you to copy the files to your computer first. If you did this the data should still be on your computer. Where did you restore the data to?  

Also there is no file size limit for SecureAccess 2.0. The only limit you could have possibly ran into regarding file size is the FAT32 file system limitation. The FAT32 File system cannot store any single file larger than 4GB however since your drive is in FAT32 anyway there would have been no way to have a single file larger than 4GB on it in the first place. I do not think the 4GB file size limit with FAT32 has anything to do with this. 

Hi there

Just now i installed v2.0 sandisk secureaccess. I copied almost all files from v1, but few folders were in big size. When i started copy large data folders, it shows 

"Microsoft Visual C++ Runtime library

Runtime error

This application has requested the runtime to terminate it in a unusal way. Please contact the application’s support team for more information."

I unplugge and plugged the usb again and checked. But still shows same error. I restarted the pc, but still same. In the last i re downloaded the v2.0 software and ran again. But still it showing same error.

I tried copying small size files also after this, but result is same.

What happened after i tried to copy large folder that v2.0 is not at all reacting

Please advise asap

I restored it the the file folder created on the desktop.  I verified all the files had been transferred successfully.  The issue was when I went to copy them from the desktop folder back to the Locker and the system crashed.  I tried to “undo” the copy and paste feature but it was too late since.

What is the problem with v2.0… really fail to understand

I have posted my problem on forum as well as mentioned in “ask question” in support section. But there is no reply from support team. 


@appoye wrote:

What is the problem with v2.0… really fail to understand


I have posted my problem on forum as well as mentioned in “ask question” in support section. But there is no reply from support team. 



Can you try copying the data from SecureAccess 1.0 to the computer then add the files to the secureaccess 2.0 vault? let us know if you get the same error. 

Do not do that unless you have a backup of the backup otherwise you risk losing all your data.  That’s what happened to me.

copying the data to the computer is a backup. 

again try copying the data to the computer and import it in SecureAccess 2.0 from there. if you use the add files option it will ask you if you want to permenently delte the sorce files from your computer. say no and let it import the files. 

The problem with what you suggest is the size of the files being copied crashed computer so the files are no longer in the desktop file folder or in the Locker.  

file size should not crash your computer. I have tested with several large files, dummy files in capacity up to 10GB and have not seen any issue. Regardless if you do not delete the vault before verifying the files are in fact there on your HDD you will not run any risk of data loss. It seems your experience was not something you will likely run into when copying the data from secure access 1.0 to the computer. 

Once again for appoye, can you try copying the data from secure access 1.0 to the computer then import the data to secure access 2.0 and let us know if you still see the same error. 

Here’s the problem and why my files were lost.  I was able to replicate the Sandisk error and took a screen shot of it but I don’t see a way to attach it or copy into this thread.  It says, “The application can not add more files because the vault’s disk is full.”  I have 14.9 gb free.  Is it possible my files are somewhere else on the disk?  It looks like only the first 20 copied over. 

You are using Mac right? When you delete files from the flash drive on a Mac do you also empty the trash? If not Mac will not actually free the space that was used by the file you deleted. 

Here is what you can try. Make sure the files are copied out of secure access 1.0 and are on your computer HDD. Once that is done open disk utility and erase the USB flash drive. if you ahve single files larger than 4GB make sure you use exFAT for the file system. Once the flash drive is completely empty download and install secure access 2.0 and import the files from your computer HDD to secureaccess 2.0. Once you have verified all files are now in secureaccess 2.0 you can delete them from the computer if you want to. 

Did what you said except I didn’t erase everything on the flash drive.  Just erased Locker 1.0 and the Vault file thinking that would free up the space.  It’s still in my Mac trash so in theory it could be reinstalled on the flash drive.   Tried that and it copied back to the USB flash drive and it looks like My Vault is the right size but it thinks its a new installation.  Poking around the flash drive it looks like the files might be in the Locker.  I counted 23 files but the drive says 24 files.  Interesting, maybe all is not lost but just hiding.


just downloaded v2 from v1.  now the only way to access the scandisk usb for me to open sandisksecureaccessv2-win.exe in my downloads file. how do i get the exe file onto my drive?


its still same.

I tried all the ways. 

1)dragged from v1 to v2

  1. copied data from v1 and saved on pc and then moved to v2

  2. used add files button in v2

  3. tried to copy completely fresh data from my computer to v2

Restarted usb, restarted pc… but the problem didnt solved. Everytime it shows same error which i have mentioned before.

can you try formatting the drive and then reinstall the software?

also what OS and fiule system in on the computer? 

does anybody ever get back to people that send in questions

windows 7

I have spent considerable time with sandisk on v2.0 -while they won’t acknowledge the problem-I’m quite certain you are right - it crashes when you try to add larger files. I will use this with v1.0 and won’t buy anymore of these (like to use several flash drives for backup). the only problem with v1.0 is it runs alot slower . B the way I alos tried encryptstick- it’s worse -at least the trial version…