SanDisk Secure Access V3 fails to start

Yes, it is the default but some people, and things, change it.  At this point the only recommendation I have then is to use the Safely Remove option on the Taskbar when you have a flash drive plugged in and want to remove it.  It’s what I do regardless of the machine I am on, including my own.

Copy that.

I still wanted to ask if this was worth any new consideration.

I moved the old SanDiskSecureAccessV3_win that doesn’t open to my desktop and replaced it with a a new one that O downloaded. It open’s but I get a “wrong path” or “vault has been moved”. Does that shed any new lights? See screen shots vault0.jpg vault1.jpg

Before you copied the new download to the flash drive did you delete all the files & folders on the flash drive?  If not please try doing that  then copy the new download over and try executing it.

WTF is this?  

Brand new memory sticks arrived today.

Launched “SanDiskSecureAccessV3_win.exe”

Immediately went into message stating update available - bug fixed etc.

Downloaded update

Then displayed a message stating failed to remove SanDiskSecureAccessV3_win.exe

Here’s a suggestion chaps - if you’re going to ship something which can potentially shag one’s data - at least make sure it works properly before depolying.

1 Like

Hey Ed,

Quite interesting what’s happening. I seriously don’t think I should give up on this drive. I went ahead and removed all but the new installed “SanDiskSecureAccessV3_win” and the vault and upon launching secureaccessV3 now I get a very interesting welcome you now have the most secure encryption … then next popup “it appears you already have a vault installed, do you want secure access to use it?” “yes” and my heat beating lie crazy waiting, hourglass and then sthg like “windows has stopped working…” . That was really close this time. I feel we should continue trying things after the holidays. I keep you posted with new developments

Hey benon1,

Good to hear you’re still enjoying the new drive.  :smileyvery-happy:

I think you should have deleted the vault files also when you restarted.  Nothing on the drive but the SecureAccess app.  In fact maybe deleting it also and with the drive completely empty starting over with a fresh download.  

Enjoy your holidays and travel safely.

1 Like


What does it mean to rename it?  How do you do that?


@shadolyst wrote:

Renaming the *.exe worked for me too. Thanks, @ssguitarist

I have been using the Sandisch Secure Access V3 for a few years now. Most of the time it works fine but around 1 in 10 times, when I click to open the file it just seems to freeze with this on screen (see attached picture).

I have tried renaming the .exe file, closing it and trying again but the only thing that seems to work is restarting my PC. This can be a pain as it means I have to save and close everything. Do you have any suggestions to fix this without shutting down?



I purchased a SanDisk Secure Access USB a few weeks ago.

I haven’t been able at all top install and run the Secure Access software.

When I launch it, it looks for updates, then says that it will restart, but then it fails ALL the TIMES.

I tried to delete the software and re-install it. Unfortunately, this is NOT an option. I am NOT allowed to uninstall/delete any file from the USB. My only option is to launch the program, which does not work.

What should I do?

thank you,


> I am NOT allowed to uninstall/delete any file from the USB.

This sounds like a Windows security app problem.  SecureAccess files are easily deletable.


I have stored files in the vault on version 3 and successfully accessed twice before today.

When I have tried to open the vault today I cant, I receive a pop message that reads: 

ScanDiskSecureAccess is already running

I have hit task manager there are no processes running,

The vault shows up on the USB window, however the only files that show under the USB drive in the computer menu on the left hand side of screen are the 3 folders:

SanDisk SecureAccess

SanDiskSecureAccess Settings

SanDiskSecureAccess Vault

not the application where all the files are:


Any ideas on how to get back into the vault?    (it is the same PC that I am trying access from that I used to copy the files across initially)

What happens if you Safely Remove the USB drive and reboot your pc and then try to access your files?


I have always safely removed the scan disk. I have also tried safe removal and rebooting the pc with no success

Check your Recycle Bin to see if the file got accidently deleted.  If not there try one of the free undelete apps posted here to see it’s still on the drive.

If that doesn’t help you may have to reinstall the SecureAccess app.

Hi guys

Just bought loads of 16GB Dial drives and had the err=1 message: Failure reading the filesystems file

After going nuts for the past hour, then reading everyone’s comments on here, I decided to try removing all SanDisk software off the drive (temporarily, to my hard drive) EXCEPT  SanDiskSecureAccessV3_win -  TA-DAAAA!! when I opened the program again, everything worked like a dream and I got the ‘Secure Access - Create a Password’ dialog box, as described on the installation instructions included with the drive. I AM NOW LOOKING AT THE MAIN INTERFACE AFTER SPENDING SECONDS SETTING UP SECURE ACCESS…FINALLY!

Renaming the .exe. file didn’t work for me, by the way. Neither did reformatting the drive. 

I’m about to transfer the other files back to the Dial drive. With a big grin on my face :D 

" I decided to try removing all SanDisk software off the drive (temporarily, to my hard drive) EXCEPT  SanDiskSecureAccessV3_win "

"Neither did reformatting the drive. "

Pretty sure reformatting the drive removed SanDiskSecureAccessV3_win.

Hopefully the other files you plan on transferring back aren’t .dat files.

Hi Ed

It looks like you either didn’t understand my message or I wasn’t clear enough - so for the sake of clarity and other people’s sanity (!)…

I had already tried to rename the v.2 .exe but it made no difference when I double-clicked on it - I still got the error message. So I then tried cutting ALL the files off the Dial (after I’d reversed the file name change), pasting them to my computer desktop, reformatting the Dial, then pasting the files back onto the Dial and trying again with the .exe file but that didn’t work either.

In the end, the only thing that worked was deleting Secure Access v.2, downloading v.3 onto the Dial, leaving that ON the Dial but cutting the other files and pasting them onto my computer desktop…leaving only the v.3 on the Dial. I then double-clicked the v.3 .exe and hey presto…seconds later everything was working. I then pasted the files back onto the Dial from my computer desktop.

I’m guessing it doesn’t matter whether or not the files were .dat files because it worked.

Thank you for the clarification bigblueamazon and for the happy ending.  :smiley:

you should have call to there customer care number where you will get help for sure. If you dont know there Toll Free Number than please visit. 

Customer Online 24/7 Information Support

I tired it … still it wound not open .!!