SanDisk Secure Access V3 fails to start

Just bought the SanDisk Ultra USB 3.0 32GB Flash Drive.

After plugging it in Win10 PC USB 3.0 port and running the SanDiskSecureAccessV3_win.exe file, it said a new version is available.

Clicked the Update button to download it. Then it said the application will now restart. But get msg ‘Failed to start F:/SanDiskSecureAccessV3_win.exe’.

Is this a known problem? Anything to fix it?

1 Like


in that case i suggest formating the drive to have a clean drive and then download the latest version of the website and try to install it again on the pc

here you can find the link where to download the latest version of the secure access:


I realise this is an old(ish) query, but I just resolved the issue a quicker way than formatting / redownloading as suggested above.

When I received the SanDisk device, the executable was named ‘Run_SanDiskSecureAccess_Win.exe’

I closed SDSA and renamed the executable ‘SanDiskSecureAccessV3_Win.exe’ - relaunched it and it updated fine.

It may be worth noting that mine complained it was still running while trying to update, however after clicking ‘Yes’ to retry a few times, it eventually updated and is running fine :slight_smile:

Hope this helps anyone else with the same issue.


An interesting approach.  Thank you ssguitarist.

1 Like

Worked for me too! Thanks, ssguitarist!

Renaming the *.exe worked for me too. Thanks, ssguitarist

1 Like

All you have to do is download the newest version and replace the .exe on the flash drive. 


Just to let other know, I had the same problem today,  June 13, 2016.  Removing the executible from the thumb drive then coping the new downloaded version worked.  – Mark –


I followed your suggestion and it works perfectly.


1 Like

I plugged in my usb to my computer and it keeps saying The application will now restart and then it says "failed to start I:/SanDiskSecureAccessV3_win.exe ". Can someone please help me?

Thank you very much, i got it :smiley:

1 Like

Thank you so much.

1 Like

My SecureAccess V3 gave a “SecureAccess is already running” error where I do not even have an option to type in my password to enter the vault to retrieve my files within the vault. I contacted SanDisk chat - and the support person gave 2 solutions:

  1. alt+crt+del > go to disk/task manager >second tab( processes)

If you can find SecureAccess there, delete it and try to open the SecureAccess again normally.

  1. If you cannot find SecureAccess there, please uninstall and reinstall SecureAccess again. Instructions are on the article bellow:

SanDisk SecureAccess 3.0 support information and download page

The 2nd solution worked for me.  It required me to uninstall the existing SecureAccessV3_win from my USB stick, then download the new SecureAccessV3 (from Download for PC on that webpage - link above), copy this new version to my USB stick to replace the older one.  Then click it to open it, and it should work.  I did not delete anything else. I think any existing files/data you have already stored into the vault is stored in the SecureAccess Vault itself, so do not delete or uninstall anything else except the SanDiskSecureV3_win!

I hope it helps.

What about data already encrypted. All the solutions I read seem to suggest complete overwritting existing files. Can anyone tell me how I get my files back when suddenly SanDiskSecureAccessV3_win won’t open? Have I lost everything?


“SanDiskSecureAccessV3_win won’t open? Have I lost everything?”


Without knowing what error you’re getting it’s hard to know what the problem is. But you should try using the drive in a different USB port and in a different pc to see if you can get SecureAccess to run again. And try running chkdsk on the drive.

Tried different port and pc except I can’t run any scan on the drive. I guess the encryption won’t allow that. Even scanned entire pc with Recuva except sandisk wouldn’t let scan in. My guess is chkdsk probably won’t either. When I click on “SanDiskSecureAccessV3_win” program reports following 4 dll’s missing, LEAuT32.dll
SETUDAPI.dll, COYPT30.dll, WIN M.dl. I downloaded the executable again, renamed to R_SanDiskSecureAccessV3_win and copied it in the drive and I can open that one with no issues. With that in mind do you still think I have lost everything? It’s my second sandisk drive that comes out with such an issue. The first one suddenly stopped allowing any writte-in. At least it didn’t prohibit me from accessing my files. this second one never gave me the opportunity to even get to the backup point since I just got a new pc and was transfering things.

“My guess is chkdsk probably won’t either.”

A bad guess IMO especially since it takes only a minute to run and may fix the missing files problem.  The missing files to me implies you are not Safely Removing the drive when your done using it.  Check your Windows settings for the USB drive and be sure they are not set for Performance rather than Safety.   


That is a smart enlightning guess. Indeed those issues I keep on having seem to all have began when I inadvertantly removed the USB drives without using the eject command in open devices. I didn’t imagine that can be such big a deal. I will look in the settings (at least for future use).

And before you give up on the flash drivers, open a Command Prompt and run chkdsk on them.  It will correct the errors in their File Allocation Tables.  Which may fix the access problems to you files.