SanDisk Sansa e280 8 GB MP3 Player battery dies


It seems like suddenly now my battery will not keep its charge after its fully charged.  I can charge it and not play the player for 3 days with the power completely off and I turn it on and the battery is completely dead.  I have to recharge.  I bought a new battery for it and the same issue.

It seems like when I first bought it I was not having this problem.  I am not sure if updating the firmware may have caused the problem.   I reformatted the drive and no luck.  Can someone give me some advice please?

If you’ve already tried a new battery and it still refuses to charge, then it can only be 1 of 3 things.

  1. The new battery is bad (unlikely, but possible).
  2. The charging circuitry of the player has failed.
  3. Your computer’s USB port is not putting out enough horsepower to charge it.

Have you tried using an AC - USB charger rather than your computer. Or maybe trying a different computer (a friend’s or work)? If it shows that it’s fully charged though, and 3 days later it’s dead, I would suspect the battery. If the problem lay with the charging end of the equation, then it wouldn’t charge up in the 1st place.

Updating the firmware would have no effect on this condition, nor would formatting it. Lithium-Ion batteries can, and do start losing their charge from the git-go, whether they are used or not, so although you might have bought what you thought was a ‘new’ battery, it might well be several years old by now and is no better than the one you are replacing.

Thank you Tape for the very clear and detail information.

I will try and use another resource to charge it.  I thought I did that before and had the same results but not sure. 

I will also try my old battery to see if maybe it just needed to die completly and be recharged again because the new one is no different then the old one. 

I am wondering if its the charging circutry like you mentioned but you also said if that is the case it would not be charging at all.  Correct?