Sandisk Sansa 2Gb Clip will not get past the Sandisk Sansa screen upon booting.

I just bought a Sansa Clip 2Gb over the weekend and hooked it up and copied a couple songs to the device and now upon booting the device displays the Sandisk Sansa logo and goes no further.  None of my computers (neither XP or Vista) will detected the device now and I have tried holding the power switch and resetting but I get the same results, any idea how I can get this to work?  Many thanks.

Anyone have any ideas, if not tomorrow I am going to take this one back and a second one I got my wife just because I can’t trust the other one to last if the first broke the first time I tried to use it.

Unplug the device and turn it off.

Set the hold switch to locked,  and press and hold the center button,  while connecting the device to USB port.

You should see the sansa device in Windows explorer.  Right click the device and format it.

Unplug the device.  Hopefully now it will be able to boot up to the music menu.

I would then select the devices format command under settings menu.  reformat it from the devices format command.

Now you should update the firmware.  Download the Sansa updater from the Support page of sandisk.com/sansa and install it.

I have tried this a about three times now, each time on multiple machines when I try to do this I get a error message that the Windows has detected an error attempting to connect to the device.  I have tried this under Vista and XP and got the same results each time.

I had the same problem.
I tried this and it worked!!
Thanks man~~~