SanDisk OTG PenDrive Failure

I just bought my OTG PenDrive (not sure if 16 or 32 GB). I’ve been using it for a month now and it suddenly failed.

My friend used my OTG on her laptop and was suddenly turned into a shortcut instead. It won’t show any files so I suspected that it was a virus.

I searched the net for any solutions for viruses and found this link I followed this link and used a different laptop since the first laptop is infected (I think) I was still able to open my OTG on the new laptop and even saw my files on it even if its just a shortcut.

I was using the cmd and inserted the command “dir/w/a” and showed none of the files showed in the link. I came to a conlusion that it was not an autorun virus (stupid me). I then closed the cmd program and removed my otg to restart the cmd to try to remove shortcut virus instead. But the laptop can’t detect the otg. I tried shutting down the laptop but it wont shut down. I even have to remove the batteries to shut it down. I tried reoping the laptop while the otg is inserted and it wont turn on. The moment I removed the otg, the laptop turned on. I reinserted the OTG but nothing happened. The laptop can detect my other flash drives but when I insert my otg, it will hide all my flash drives instead.

The moment I inserted the otg on my phone, it suddenly shut down instead. I tried this for 3 times and it keep on shutting down. I downloaded OTG troubleshooter and it says that there is no device detected in linux and android.

Can someone help me? Please