SanDisk media converter messes up every time for me

I used the upgrader to get the newest version of media converter, and I’m using Windows XP SP3. I start media converter, connect my e260 which is recognized by media converter as well as Windows. I add the .avi files I want to add to the player and it starts converting the first file. At around 5%, the e260 vanishes from being recognized in media converter, which continues converting but doesn’t put the files anywhere and states at the end that all files failed. This happens every time. I can easily transfer audio files via Windows Media Player to the same e260. I’ve tried converting the .avi’s to .mov and then just copying them to the /VIDEO folder on the e260, but they won’t play, the e260 states that I should use media converter to transfer the files. I would if I could but media converter won’t cooperate. I’ve reinstalled media converter 4 times and nothing has changed. Any ideas?

Do you have a v1 or v2 player?

Have you tried switching the USB mode (on the player) to MSC?