SanDisk iXpand App keeps crashing when i open videos

Hi! I currently bought my iexpand mini 32gb and i am having issues. Whenever i play any type of videos, the SanDisk iXpand drive app (5.0.2) keeps on crashing! I already tried deleting and reinstalling the iexpand app in my iphone 5s (ios 9.3.3), in my ipad mini (ios9.3.5) and i tried it in my iphone 8plus (ios 11.3.1) but the same thing still happens! The app opens properly, but when i try to play any type of videos or movies, the app just crashes. Does anybody have the same issue? Please help. Any advice would be appreciated! 

5.0.3 is out now. I would recommend updating and see if the same issue occurs. If so what is the video file type and codec?

I have been having the same issue. I’ve been using ixpand for almost a year now, and the app worked great until I installed the lastest update. Now whenever I open a video, the app will crash.

Here same behaviour cannot playback video’s anymore (photo’s are fine).Used to work as a charm.

All videos I playback crash the app, no matter what extension I try: Avi, Mov, MP4. Also small video’s

iPhone 6S, iOS: 10.3.3, App version 5.0.5, internal mem. 1.3 GB available, preview thumnails look fine.

Deleted app and reinstalled it, restart phone, but no success…:cry:

Anybody has suggestions? thnx!


I tried deleting the cache in the app, no success…

But…Deleting the LOST & ixpand folder on the thumbdrive with a PC dit the magic!

The drive seems to work fine again and plays back all videos! .:smileyvery-happy:

So try to delete the ixpand dir on the thumbdrive.

1 Like

Just purchased the 256gb ixpand drive and downloaded the app (v5.08) and it crashes constantly… like every 2 seconds or so. There is no lost directory on my drive. Any thoughts? The drive is presently unusable on my iPad Pro!

contact sandisk support. you can send the iOS crash logs to them and they should be able to figure out what is causing the crash. 

Same here, just bought the 128gb drive but the app keeps crashing after the scanning for new items process

Hi SanDisk,

Please update your apps, as it crashes every time when using. tried many times the delete and install but the same thing goes. This is the first time I encounter this issue as I’m using your app and device for a long period already. I hope you make some action immediately.

I was having same problem and it worked great at first but I put it in my laptop and opened it and deleted unnecessary folders and it actually works now so give that a shot. It should work. Good luck !