Sandisk GLIDE 32GB Write-Protected problems

i just bought Sandisk Glide 32GB a few weeks ago and yet this USB had write-protected, i can’t copy data.
do you have any solution for this problem?

There’s only about 43794871368 posts on the forum here about this issue.

Return it. :wink:


First, SERIOUSLY, return it? Sure, hand over all my personal files to get a replacement, derp!

Just had it happen to me, only had media player running and tried to run a backup batch file, got the write error (win7e).

Ejected and retried, then rebooted after the same error, no good.

Then i launched media player after reboot and it reported an “error exiting last session” error - hmmm this is new.

WMP is known to search for media files in the background, even if your have the SYNC features turned off.

I don’t have any add-ins, it was raw WMP that i’m pointing at.

I’m suggesting it tried to update 1 or more media files (artist, album or whatever) and caused the problem.

PLONK, to the old watch drawer!

Dang, the Kingston’s are so ugly, i guess the tiny HP looks good…

HAH, i take it back and will try this one…

PLONK, to the old watch drawer!

Open the old watch drawer and try this fix.—how-to-fix-write-protected-disks

Exactly same problem here with my  32gb cruiser fit, i have had it just over a year now so i highly doubt they will exchange mine.

I had a simillar problem with a 16gb Transcend usb stick with write protection errors but on their website they have a program that can fix write errors.

:smiley:   Hi The One,

_ Dear member of SanDisk Community, welcome. _

Hmm… See here, and you might have a pleasant surprise.

To find out more on this, see here:

If you want, experimenting with possible solutions, see here:

If you are angry, and think to change brands, before see here:


Regards, Alfred.