Sandisk flash drive will not eject from my laptop

I recently updated my computer from Windows7 to Windows 11. My SD flash drive worked fine on the Win7. I plugged into my Win11 laptop, it worked fine. However, I am not able to get it to eject safely. Even though I have closed all my files, I receive a message that it is in use. I have shut the machine down and started again. Went into settings. Any other options out there?.

Plz check the Task Manager for any processes that might be using the flash drive. You can also use third-party tools like Unlocker or Process Explorer to identify and unlock the processes using the drive.

Besides safely ejecting the USB drive through the taskbar, you can do the same thing using CMD.

  • Open Command Prompt as an administrator.
  • Type diskpart and press Enter.
  • Type list volume to list all drives.
  • Identify your flash drive from the list.
  • Type select volume X (replace X with your drive number) and press Enter.
  • Type the remove command and execute it.

As a last resort, you can shutdown the computer and remove the flash drive after the system has completely powered off. While this is not ideal and should not be done frequently, it ensures that no processes are using the drive.