Sandisk Extreme USB 3.0 unusable as Windows Install Medium all other USB 3.0 Sticks work


i’ve explained the problem detailed in the following thread, please read it complete to understand what is the problem.

In Short:

The Problem is at the Windows Setup Stage where you select the partition to install to it’s unpossible to click next:

An error message appears that says: cannot find any partition or create one to install to… but the hdd is visible and its also possible to create and delete partitions… so the error message is bull**bleep**.

My thougth is that the sandisk stick is detected as sata hdd and is internally mistakenly mappen as first hdd, if i pull the stick out at the stage where i select partition, click refresh, connect stick again, another refresh then i can install to the hdd.

What is wrong with your extreme sticks? Any other usb 3.0 stick is working well.

To pull the stick and so on is just a dirty workaround, i bougth the stick because of the speed!

Greetz X23


this is what i expected… silence! Nice done

Greetz X23

Dear Mr. and Mrs. Sandisk,

what about a statement to this problem?

Don’t you like your customers?

Greetz X23

"Not just any USB drive can be used in this environment and Microsoft has set up specific testing requirements that the USB drive manufacturer must meet in order to be a supported device. Currently there are five USB Flash memory devices listed as supported by Microsoft for Windows To Go[12] :[13][14]

  • Imation IronKey Workspace[15]
  • Kingston DataTraveler Workspace[16]
  • SPYRUS Portable Workplace[17][18]
  • SPYRUS Secure Portable Workplace (w/ Hardware Encryption)[19][20]
  • SuperTalent Express RC8[21]"

Not “all other USB 3.0 Sticks work”.



no one was talking about windows to go…!

You haven’t read the linked thread right?

Please do and then you might think about your answer.

You will find the most important information on page 3 if you

don’t have the time to read them all.


 dotfusion, on 27 Feb 2013 - 23:21, said: @x23piracy, I have searched high and low for more more information ob this odd behavior. But all i can find is either not reliable or solutions such as the one tried. No real reason as to why or what is the problem. I suspect it has something do to with the way the partition tables are setup on the source media (in this case a san disk usb drive.) I would start there. amaltom61, on 01 Mar 2013 - 12:41, said: I had the same problem with a 2.0 8 gb drive. I found a fix on the net, Just create about 150 mb or more of unallocated space in the hdd or ssd you are trying to install windows Resizing a partition would do the trick but do a full back of the drive just in case Stimpy, on 01 Mar 2013 - 17:12, said: Windows setup will run a refresh on the USB bus at the point that you are having problems with. One way to get around it, is to pull the USB disk out, then put it back in, and go back one step of Windows setup, and try again. This works in most cases with this error. bphlpt, on 01 Mar 2013 - 17:15, said: The questions remains. Why is this happening with this particular brand/size of USB stick while it is not happening with others, and how to prevent this behavior? Cheers and Regards Stimpy, on 01 Mar 2013 - 18:46, said: It's a good question. I also own the same drive, and have the same issue with it. I have a feeling that the controller in the stick is slow at initializing, and is simply not fast enough for Windows Setup. If you watch the USB stick when Windows is setting up, you can see that it's being initialized, (just before setup asks what drive you want to install Windows on) as my mouse and keyboard also disconnect and reconnect at the same time. amaltom61, on 02 Mar 2013 - 13:05, said: Stimpy can be correct. One way i found to solve this problem is to create some unallocated space in the drive(150 mb or more).     bphlpt, on 04 Mar 2013 - 08:00, said:

    Even though you weren't talking about that, I don't know why it wouldn't work.  I've reformatted them before, Fat32 and NTFS.

    OK, I went looking for references.  Yes you can do it, but it seems it is not as easy to do as I thought, at least for everyone.  Some folks say the standard built-in Windows 7 tools do it automatically, some say they don't.  I still haven't tried it, since I don't have a USB stick available to partition at the moment.  Some references say that that you need to flip the USB removable bit so that Windows will see the stick as a fixed drive before you can partition it.  I also found  two different tutorials or how to partition a USB stick here and here.  So, yes, one way or another it can be done.

    Cheers and Regards

 Stimpy, on 04 Mar 2013 - 16:59, said: Yeah, I have looked in to this a while ago. And found that you cannot partition this USB stick. It needs to be seen by the system as a fixed drive, but for whatever reason, Sandisk are not interested in helping their customers out with this, as it is a simple change to the drives firmware, like you described. There is a rumour going round that Sandisk are going to realease an updated firmware that will make this drive compatible with Windows To Go, and turn it into a fixed disk. I think that's unlikely, but you never know! Have a look here, it seems Sandisk support simply does not care.

Greetz X23


Try the following.

Download MiniTool Partition Wizard Home Edition. 

Select USB stick, and delete the partition.
Create a new partition - FAT32.

Apply and close Minitool.

Download PLoP Boot Manager:


Start unetbootin-windows-585.exe - and select ISO and PLoP’s file called “plpbt.iso” and write to usb stick.

Then download - YUMI – Multiboot USB Creator.

Start it, select USB stick.

Then select the ISO you want to write to stick.

Insert usb stick into PC that will not boot or write correctly from USB stick and check if it works…

Crossing fingers :slight_smile:
/ Stig Henning

why sandisk don’t update firmware to repair this isue?

i love the speed of this stick, i’m it manager i install OS every day. on windows i remove stick and i putit back.

why sandisk don’t update firmware to repair this isue?

Because it’s Fixed by design to meet Microsoft’s Windows 8 to Go requirements.  You need to get updated software that supports Fixed removable USB drives.