SanDisk Extreme USB 3.0 (64GB) Flash Drive not working

New USB flash drives don’t need to be formatted.  They are formatted at the factory.

but the device is fat32, you must change it to ntfs. in any case it dosen’t work

To my knowledge all flash drives come formatted as FAT32. The only reaosn one would need to re-format to NTFS is if they needed to transfer a single file over 4GB in size.

I have the same problem with 2 drives of this model. Tired formating on 2 PCs (one XP, one Win7) and cannot format to NTFS even with Diskpart in command mode. The drive also cannot be read in MAC (one 2011 w USB 2 and another 2012 w USB 3). Partition or format in MAC fails.

Shop will not refund, called technical support and was asked to get replcaement which will not solve problem. Need Sandisk to provide a solution for:

  1. format to NTFS

  2. MAC OSX compatibility

1 Like

Just got a 64 and a 32gb in the mail and they were strangly dropping out then back on when connected to usb 2.0 every know and then but when plugged into usb 3.0, where I have a usb 3.0 dock w/hdd that work great, it would just pop in and out ever few seconds.   Made the mistake of thinking something might be up with the data on teh drive so I did a quick format and of course it would effectivley just sit there and fail no matter what setting I used and is now useless.
So I have over hundred dollars in usb 3.0 flash drives that don’t work with USB 3.0, didn’t work consistantly in usb 2.0 and one now that is a brick.   Really wish I would have found this forum or read some of the Amazon comments before making this mistake.   They must have screened the ones they sent out to reviewers.

Should have mentioned, for what it’s worth, that the systems I tried it on were a windows 7, windows 8 rtm and windows 8 CP.  All 64 bit. All same results.  Saw people with Mac’s and XP having simliar issues in other forums.

“Just got a 64 and a 32gb in the mail”

In the mail from whom?  eBay?

So I have the same exact problem.  I received a 64GB extreme USB drive and as soon as I tried to copy files the copy failed and the system froze up.  I could read the files on the drive just fine.  So I tried to format the drive using the exFAT file system but the format fails every time.  It almost appears like the drive is write protected or the drive shuts off and stops communicating after a few seconds.  This is the second drive that I have, and both have resulted in the same issue.  

Read this posting.

Even though I am not exactly know what caused your problem, I also would like to give you some suggestion.

1.You should firstly back up you data for the safety of it.

In you case, you can only read the data, cannot copy or format it. You should restore the data there with the help of recovery software in case of any data loss. After all, nobody can make sure whether the following steps or measures can damage the data.

In regard to the recovery software, you can read some articles of recovery thing to help you make a right decision:

Tested Data Recovery Freeware

Format Recovery

Not Format Recovery

2.Remove the write protection

From you description, I think your drive may be write protected. You are supposed to remove the write protection.

You can get the detailed steps of disabling write protection in this article:

I wish I can help you out. Good luck!

I had the same problem.

My mac hangs when I plugin the flash disk

It was detected in XP… but when I tried to reformat using HP format tool, it fails to format… using FAT32 and FATex


I used Easus Partition Manager… deleted the partition and created a 32gb primary partition… formatted… now it’s usable in windows and mac… but using 32gb… at least I was able to use it.

Just received my nice new Extreme 64GB flash drive in the Mail from…  Plugged it into my Windows 7 Pro PC (USB 2.0) and I can’t do anything with it.   I can see the files that were already loaded on from the Factory but I can’t even create a new folder.   I’ve tried several things including restarting the computer but Not formating.    Why do they sell a product that doesn’t work???  I guess the “EXTREME” stands for EXTREME measures need to be taken to get it to work…    I guess I’ll have to send it back to TigerDirect - After I give it a BAD Review…   

My PC is:

Toshiba Satellite L755D-S5104

Windows 7 upgraded to Professional SP1 - 64bit of course

AMD A6 Quad core processor

4GB Ram

If anyone who is more computer savy then me can figure out how to get this to work - I really would appreciate a heads-up!

Easeus worked for me too, apparently windows can’t recognize more than the first partition on a removable drive, there are three partitions on 64gb drive, I deleted them all and then formatted with ntfs, works great now

I was looking online for solutions because my SanDisk Extreme 64GB USB 3.0 Flashdrive had the following problems

-SanDisk Extreme wasn’t being detected as “SanDisk Extreme” in Device manager. Instead, it was being detected as various different Disk Drives.

-SanDisk Extreme couldn’t be given a driver label in Computer Management under “Disk Management”.

-SanDisk Extreme would be detected in the Computer, but wouldn’t appear as a removable storage device in the “My Computer” window

-SanDisk Extreme was detected and usable when inserted into 2.0 USB ports but not in USB 3.0 ports.

-SanDisk Extreme’s LED when inserted to the drive will stay on and the USB flashdrive will not be detected by the Computer

-SanDisk Extreme’s LED will turn on once inserted into the USB 3.0 Port but then turn off approximately one second later and will not be detected by the Computer

I’m running Windows 7 64 Bit.

After running tedious and unsuccesful solutions and procedures found online e.g deleting registries from the SanDisk Extreme, trying to assign it a Drive letter, resetting computer to factory settings, I found a solution.



  1. grab your SanDisk Extreme and slowly, but not completely, instert it into the USB 3.0 Port.

  2. Make sure the USB stick is NOT COMPLETELY INSIDE THE PORT.

  3. As you’re inserting the stick into the port, the LED in the USB drive should turn on. From here a couple of things can happen

  4. option 1: The LED will begin to blink. This means that the USB drive has been detected by your computer and is fully functional

option 2: The LED of the drive will stay on and not blink: try re-doing steps 1-3.

If the LED of the Flashdrive remains on once halfway inserted to the USB port, try inserting it completely into the USB port.

This has worked on me all the time.  I don’t know if it’s a software or hardware issue, but the solution above has worked on all devices that couldn’t get this device to function properly in. 

If a video is needed to provide a solution to this porblem to be credible I will do it. (:

Have a good day everyone!!


Interesting.  Strange, but interesting.

Thanks for posting nacoly.

Thx, fixed my “brand new” 32gb Sandisk Ultra and my 32gb Sandisk Extreme.


This solution completely worked for me.

Search for “Mini Partition Tool” and delete the current partition and again choose the partition and after that format it.

may be Current/ Primary Partition.

nacoly’s solution is easier.  And doesn’t require loosing all the files on the drive.

My sandisk ultra usb 3.0 screws up my excel save function. After saving a file to my sandisk I cannot then save the same file to my computer. Gives some unhelpful message. Any ideas?