SanDisk Extreme USB 3.0 (64GB) Flash Drive not working

I was looking online for solutions because my SanDisk Extreme 64GB USB 3.0 Flashdrive had the following problems

-SanDisk Extreme wasn’t being detected as “SanDisk Extreme” in Device manager. Instead, it was being detected as various different Disk Drives.

-SanDisk Extreme couldn’t be given a driver label in Computer Management under “Disk Management”.

-SanDisk Extreme would be detected in the Computer, but wouldn’t appear as a removable storage device in the “My Computer” window

-SanDisk Extreme was detected and usable when inserted into 2.0 USB ports but not in USB 3.0 ports.

-SanDisk Extreme’s LED when inserted to the drive will stay on and the USB flashdrive will not be detected by the Computer

-SanDisk Extreme’s LED will turn on once inserted into the USB 3.0 Port but then turn off approximately one second later and will not be detected by the Computer

I’m running Windows 7 64 Bit.

After running tedious and unsuccesful solutions and procedures found online e.g deleting registries from the SanDisk Extreme, trying to assign it a Drive letter, resetting computer to factory settings, I found a solution.



  1. grab your SanDisk Extreme and slowly, but not completely, instert it into the USB 3.0 Port.

  2. Make sure the USB stick is NOT COMPLETELY INSIDE THE PORT.

  3. As you’re inserting the stick into the port, the LED in the USB drive should turn on. From here a couple of things can happen

  4. option 1: The LED will begin to blink. This means that the USB drive has been detected by your computer and is fully functional

option 2: The LED of the drive will stay on and not blink: try re-doing steps 1-3.

If the LED of the Flashdrive remains on once halfway inserted to the USB port, try inserting it completely into the USB port.

This has worked on me all the time.  I don’t know if it’s a software or hardware issue, but the solution above has worked on all devices that couldn’t get this device to function properly in. 

If a video is needed to provide a solution to this porblem to be credible I will do it. (:

Have a good day everyone!!


Interesting.  Strange, but interesting.

Thanks for posting nacoly.

Thx, fixed my “brand new” 32gb Sandisk Ultra and my 32gb Sandisk Extreme.


This solution completely worked for me.

Search for “Mini Partition Tool” and delete the current partition and again choose the partition and after that format it.

may be Current/ Primary Partition.

nacoly’s solution is easier.  And doesn’t require loosing all the files on the drive.

My sandisk ultra usb 3.0 screws up my excel save function. After saving a file to my sandisk I cannot then save the same file to my computer. Gives some unhelpful message. Any ideas?

“Any ideas?”

Save the file to the computer 1st than save it to the flash drive.  :wink:

I have  SanDisk Extreme USB 3.0 (64GB)  but when i connect it to my PC it says 31.9 free of 31.9 so what happened to the other 24gb? 

I have  SanDisk Extreme USB 3.0 (64GB)  but when i connect it to my PC it says 31.9 free of 31.9 so what happened to the other 32gb? 

Did you reformat it?

Yes when it showed as 31.9 and no change

Is this a new drive?  If so I would say it’s a counterfeit.

No it was bought brand new in it wrapper

Counterfeits come in wrappers also.  That’s how they look real.

Have you looked at the drive using Disk Management?

32.00 GB FAT 32  also 27.63GB unallocated

just did a bit and now its 59.4 GB free of 59.6 GB

Excellent.  So the question is, how come it wasn’t fully allocated.

Good to hear Alan.  Thanks for the update.

I have no idea on that 1 but im just glad its woking thanks all

I love you, I just made an accout to thank you.

Please review this issue SanDisk!