Sandisk Extreme USB 3.0 32GB ---> No LED


after sandisk 8 GB USB 2.0, 64 GB USB 3.0 and 128 GB USB 3.0 I decided to buy a 32 GB.

What a mistake!:angry:

It works fine except the blue LED does not work.

SanDisk support promised it has a blue LED and I get another as replacement.

The new USB stick also has no LED.

What can I do?


Have you tried it in different USB ports?  Or in a different pc?

Thanks for reply.

Yes I did.

In different USB ports and in the USB ports of my TV.

The stick is working except the blue LED. I have no problems with reading or writing but I don’t know wether the process is ready or not. When I take off the USB too early, I lose data. I already made this experience. :O(

In the hardware manager it is known correctly.

I also have a 64 GB stick. Both are identical in construction. The 64 GB works correctly.

I also have 128 GB and 8 GB. They also work properly. (All SanDisk)

On my PC I have USB 2.0 ports but that should not be the problem.

Interesting.  It could indeed be the USB 2.0 ports and I’ll bet the TV has a 2.0 port also.  See if you can find a neighbor or relative that can stop by that has a pc with a 3.0 port and try it in their pc and see if the light works.  If so it’s definitely a USB 3.0 situation.  If not its a SanDisk problem.  And it’s a free replacement if that’s the case.

Hi Ed,

I guess it could be possible that the difference between USB 2.0 and 3.0 is the reason.

USB 3.0 needs more power then USB 2.0.

But all my other USB 3.0 work. And two of them are SanDisk and one has the same method of construction ( 64 GB ).

And a problem: I don:t know any guy who has USB 3.0.:flushed:

Maybe I should go into a computer shop.


At first I sent SanDik a video.



I put the USB into the USB-port for HDDs in my TV. Then I started recording and the LED flashes sometimes.

The USB HDD port has more power.

Hmmmm indeed.

It’s possible a contact between the USB plug and USB port are oxidized or dusty.  I have a USB port on the back of my desktop pc that gets erratic after a year or so.  I’ve found cleaning it, ever so gently, with emory paper restores it to working condition.  Maybe, may be, something similar is your problem.  Maybe plugging/unplugging the new USB drive into a port a few dozen times will help clear any oxidation problem on your drive.

This link is interesting reading also.

Good luck. :smiley:

I guess that isn’t the problem.

I use my favorite USB port on PC many times each day.

But on this PC I tried four different ports.

I tried on my TV. I use it also two times each day because I watch videos from USB-stick.

I tried on my SAT-receiver and on my DVD-player.

All this ports cannot be erratic together.

Only success I had on the port on TV, where a HDD has to be inserted.