Sandisk extreme usb 3.0 16 gb strange issue

Hi all i write because i have a strange problem, i can write on the usb flawless with a 50mb/s rate but when i read from it after a start at 140mb/s it drop on 0 mb/s and the read don’t proceed beyond, and in windows task manager i see a 100% usb use, in that moment the usb became unresposive and the only way is to disconnect it from the usb port :confounded:

I tried to update the usb 3.0 host driver but nothing changed

Any idea?

:smiley:  Hi,

Please, can you try your UFD on other computers?
So, we delimit the problems and then see.

Regards, Alfred.

Hi, sorry for the absence but i didn’t had a usb 3.0 device to test with, now i have sufficient information to reply, so i tried my usb on my desktop with 2.0 port and everything go well… notebook 2.0 ports and everything fine, another pc with 3.0 ports and flawless, so obviously the problem is with my 3.0 host controller, tomorrow i will do some more test on my pc in the meantime every suggest is well accepted and thanks :slight_smile:

:smileyvery-happy:   OK!

:smileyvery-happy:  OK!

Please, see link:

Regards, Alfred.

Thanks but i had already tried that kind of solutions and it didn’t work, but today i did another test and the result is odd, i used the port on the back on my motherboard (gigabyte GA-970A-UD3 (rev. 1.2)) and everything goes right :confounded: i deduce at this point that the problem is in my front panel controller… now i will try to unistall the driver of the only front panel hub and reinstall to understand if is hardware or software related

Ok i don’t know how to edit my previous message to update the situation .-. btw i do 3 other test:

  • without driver (windows legacy) the read speeds jump to 200 mb/s (that’s absurd o.O) and the front panel still block the read operation
  • with driver downloaded from my mobo site the read is 145 mb/s and the front panel drop to 0mb/s 
  • with driver downloaded from etron site same as above

so i think it’s hardware related but before close the thread i will wait some other reply or solution just to be sure 

Open the case and check the cabling to the front ports.  It’s also possible they don’t have sufficient voltage like the ports on the back.  I ended up installing a small hub on my desk connected to the ports on the back of the machine to resolve a similar problem.