Sandisk Extreme Pro USB 3.1 Help!

I’ve always hated having to create an entirely new account just to make one post to one website, but whatever, I’m droning on. Anyway, my 256 GB SanDisk Extreme Pro 3.1 USB Flash Drive was working perfectly fine until two days ago… I was transferring some files from the SecureAccess Vault (V3) to my computer, and it was working fine until it randomly decided to stop and displayed some sort or error message (I don’t remember exactly what it said) and then crashed.

Anytime after this event, when I plug it into my laptop, sometimes it will work and detect that it’s there so I can access the folder, but most of the time it won’t. Even if it doesn’t detect that the flash drive is there, it makes the noise that it does. The times when it does work and I can access the folder and go into the vault… the second I enter the correct password it stops responding, then it kind of “freezes” my computer where I can’t use the taskbar and my screensaver goes completely black until I take the flash drive out, and the computer goes back to normal function after that.

I have even tried this on another computer, and it was met with the same results. So my question to you guys is, is there any way to have the flash drive and vault work properly without losing all my data? It really is a shame that this is happening now, considering I have only had it since December 14th, 2018, and have only used it a little over 30 times in total now. Thanks in advance…

1 Like
  1. Run CHKDSK for the flash drive.

  2. When done Safely Remove the flash drive.

  3. Reboot

  4. Reinsert the flash drive.

  5. IF you can access your files offload ALL of them to the hard drive ASAP…

What you do with the flash drive after backing up all your files is up to you.

BTW There are no moving parts in the flash drive so if it stopped working whatever was accessing it or the system it was plugged into was the problem.  The system didn’t have enough power, overheated, the security apps interferred, something else on the system was running and using RAM, etc, etc.

I’m not sure if I did it right, but it says invalid parameter. The computer detects it’s “there” when I choose to scan for hardware changes in the Universal Serial Bus controllers section. If I try to go into the flash drive after that, it ends up freezing until I take the flash drive out.

Command Prompt.png

The capacity does not display either.

Once I scan for hardware changes, it shows up in the file manager, and just like the picture above, with no capacity shown. Also, I’ve tried it on another computer, with the same results.

chkdsk e:

and depending on the results of the above run:

chkdsk e:  /f

Note a space between the : and /

Still nothing, sadly (the letter changed to “f” because I was using an sd card earlier.) “Cannot open volume for direct access.”  So, is it beyond saving? Have I lost all of my precious files due to a faulty usb? Say it ain’t so!

Also, I tried another flash drive earlier yesterday, and it worked just fine. I don’t know why the Extreme Pro one just decided to stop working out of the blue…

Well we now know the pc’s port is working.  If the files on the flash drive are important you should consider the services of a professional recovery service.  Perferably a local one.