Sandisk Extreme 64GB - Slower write speeds after system format

most above average users would just look at the fat32 and format it right away.

Not if they are young users.  They buy something, expect it to work and use it.  Only if there is a problem do they look for something that may fix it.

You need specialised technical knowledge to know not to do this.

No, you just need to have less free time. 

And congrats you now ruined your expensive 64 gb flashdrive,

Have you written to Microsoft informing them their Windows 7 utility has ruined your flash drive? 

What format did the Windows 7 utility format the USB drive as?  NTFS?  Can you convert it back to exFAT and not loose the Windows 7 boot capability?

Since you seem a bit technical here’s another option.  The Windows boot functions create an ISO file before writing it to the CD/DVD/USB drive. Rather than have Windows write it to the USB drive, stop the function, then manually reformat the drive to exFAT and use RMPrepUSB to make the drive bootable and put the ISO file on the drive.  I believe RMPrepUSB supports that without reformating the drive.

I would rather format a drive over deleting 30,000 puny files and folders from a flash media.

30,000!!  Wow!!  That’s a lot of files.  Since I have never had to do that many on a USB drive I can’t imagine how long it would take.  If you’re happier with reformatting then by all means do it.

I guess everyone has their preference then.

What do I do if I didn’t save the Flash Disk details and partition ?

I’ve seen a lot of people post about slowness on their speedy drive.

There are a few reasons for why this is happening:

1: It’s plugged in a USB 2.0 slot. Generally, USB 3.0 slots are marked with a blue color, or they will have “SS”/“SuperSpeed” logo near them. Sometimes they will not, but this is fairly rare.

2: Chipset drivers. This is fairly common with fresh installs of windows 7, and sometimes with windows 8 depending on how new the motherboard is. Install USB 3.0 drivers and the speed will come back.

3: The device you are reading or writing to just isn’t fast enough. This is going to be the most common reason the transfer is slow for platter drives. The fastest platter drive with zero fragmentation is going to max out around 150-170 MB/s, the average consumer drive is going to be closer to 100-120 MB/s, and when fragmentation is thrown in that could be as low as 30-70 MB/s.

Sector size is a bunch of crap. I’ve set my device to NTFS 4k, NTFS 32k, FAT32 32k, all 3 had the same sustained transfer rates of around 190 MB/s. Sure, there may be minor differences, and I suppose in the right situation/environment it could make a significant difference, but for a majority of people it will not change anything. Which, if you guys want an easy way to format the device into whatever file system - Rufus - will do anything you want.

4: The Sandisk Extreme 64 GB is literally a SSD hard drive on a USB Stick, except that there is no easy way to force the drive to perform a TRIM operation. -

#4 is the one that will catch people eventually. The lack of trim support in windows really hurts the speed of the drive over time. Formatting the drive will not fix this, no matter how you format the drive. As the drive is used over time, and files are deleted in windows from the drive, windows never tells the controller on the drive where it has deleted files. So, it starts to stumble over itself trying to find empty space to put new files.

I’m honestly not sure if there is a way to force TRIM on the drive. However, there is a workaround, but unfortunately it’s not the easiest thing to do.


SecureErase sends a command to the controller on the SSD, telling it to “shock” the drive and wipe everything on it. This resets everything on the drive, and effectively makes it brand-new again. Just be warned that it will not have a file system, it will be a raw drive that you will have to format to NTFS/FAT32.

Also, be warned that there are a lot of programs that use the words “SecureErase”, but they do not perform the function I mention above.

Unfortunately the only easy way to do this command is with parted magic.

Parted magic is so far the only thing I have seen that correctly sees the Flash drive as a SSD device with secure erase capability. However, it works. After a month of heavy-use, I was starting to get 20-30 MB/s write speeds on my device, and after running parted magic, the device was back to 190 MB/s.

(Part of the reason I’m posting here is hoping that someone has found a way to force trim/secureerase inside of Windows. :slight_smile: )


Something that may throw a wrench in secure erasing the sandisk drive. I didn’t notice this because I have an SSD already in my computer, but apparently Parted Magic will not allow you to secure erase the Sandisk USB Drive if it cannot detect a hard drive with the capability to secure erase itself. It just disables that menu, not checking to see if the usb devices can, I guess.

Oh, and I forgot a step, when you open the “ATA Secure Erase” program in Parted Magic,  you will need to “Show all devices” 

After that, the USB devices will show up.

1 Like

Still have not a true answer, why i need care about my USB so much like that, i’m not a super advance user, why i need care about how to format my usb in a right way. after all my Extreme Pro sitll have  40MB/s speed (while it should 240Mb/s) :frowning:


Hello there,

I am in the process of replacing my first Sandisk Extreme 64 GB due to speed issues. I was tinkering with Parted Magic but I cannot make the flash drive appear on the list. The notice “This routine can only run for disks supporting the Security Mode feature set” keeps showing up. I managed to have my external USB HDD shown in the list, but not anymore.

How did you manage to make the flashdrive appear on the ATA Secure Erase list?

Thanks in advanced

Nevermind, I was running Parted Magic on a Virtual Machine. I burnt the iso on a Usb stick and booted my laptop to a true non-virtual Parted Magic session. My internal HDD was recognized and thus I could ATA secure erase my Sandisk Extreme.

Writing speeds went from 10 mb/s to 190. Could not be happier. :slight_smile:

Again, thank you for the tips on bringing this flash drive back to life. 

hey guys,

I’ve just bought a Sandisk Extreme 64 gb and wait for it… I’d like to format it to extFat, even before the first write/read. Reason: need/want larger files than just 4gb. So today I said to myself let’s a bit of reaseach and I was really afraid to find this thread and well here we are. I mainly bought this flash drive because its well promoted speed and don’t wanna lose this feature.

So for those who were able to recover original speeds (e.g with parted magic), have you guys formatted to fat32 or got the original speed with other formats?


SanDisk drives 64GB and larger are factory formated as exFAT.

I’m not so sure about that or… have I just got a fake?


I’m a huge fan of Western Digital and WAS a fan of SanDisk but after owning this stick it will be my last SanDisk purchase.

I work in I.T. and have formatted hundreds of drives. It’s a very common thing and i didn’t think twice about formatting this stick. The effort i’ve put in to get this back to a decent state is stupid, and it’s just not possible, the write speeds are less than that of a standard USB 2.0 stick. I’ve even tried aligning the partitions as previous posts have suggested but no dice.

For anyone who finds this thread in the future, make sure this is your last SanDisk purchase, they don’t deserve your money.

Or just make sure you don’t blindly format it cause that’s what you always do.  New flash drive = new technology = new use proceedure.  If you’ve been in IT for any period of time you should have seen other equipment and processes change, flash drives are no different.

" i didn’t think twice about formatting this stick"

If you want to make sure this is your last Sandisk drive you will have to think twice before buying another drive.  Sure you’re up to it?  :stuck_out_tongue:

Sure, technology changes but there was no warning that came with the stick about formatting and worse than that SanDisk have zero tools to format or restore it to its former glory. Really the only way someone would learn not to format these sticks is by formatting them and then searching for a solution when it goes belly up. Otherwise there no way of knowing this specific issue (and it is an issue).

Like i said, i’ve got USB 2.0 sticks that now outperform the write speed on this stick, and this stick was not cheap. I’ve lost all trust for SanDisk now, as much as i like their products i cannot go back because of how terrible this has gone. I mean, where the hell is some formatting software from SanDisk? It doesn’t exist and I’m now moving on to better products, at least they will work as intended.

This is exactly what the issue is about. Formatting the factory filesystem has absolutely nothing to do with the slowing speeds and I don’t know why it’s being said that causes the problem. I’ve got 2 of these drives and one I formatted to NTFS and the other is still exFAT and both have slowed down in write and reads.

Using SecureErase in PartedMagic has restored it back to normal but surely the flash drive controller should be doing this automatically. I’ve already contacted the retailer I bought it from and requested to return them. You shouldn’t have to manually maintain the drive yourself to keep it working fast. It would have been a great USB drive if it weren’t for this issue.


>>Using SecureErase in PartedMagic has restored it back to normal

when you said “it is back to normal” by using SE/PM, I’d like to ask you 2 questions on top of this:

  1. are you confirming the read/write speeds are back to the from factory speeds (up to 190 writting/up to 245 reading)?
  2. if yes #1,  what format have you choosen for to get them back (e.g. fat32, extfat, other)?


@zakear wrote:



>>Using SecureErase in PartedMagic has restored it back to normal


when you said “it is back to normal” by using SE/PM, I’d like to ask you 2 questions on top of this:

  1. are you confirming the read/write speeds are back to the from factory speeds (up to 190 writting/up to 245 reading)?
  2. if yes #1,  what format have you choosen for to get them back (e.g. fat32, extfat, other)?


Hi zakear,

  1. Yes, I used CrystalDiskMark to test read and write speeds on two different 64GB drives. One was formatted to NTFS and the other was left as exFAT like when it came from the factory. The speeds were roughly about 32-34 MB/s read and 12-15 MB/s write on the sequential parts of the benchmark. Both drives were performing similarly poor after having been used for a year and filled up many times.

  2. After the SecureErase (I booted to linux and used hdparm instead of the gui tool as I couldn’t see my flash drive. See this page on what commands to use.) the drive no longer has a filesystem so I formatted it back to NTFS 4K cluster size using Windows 10.

I went and performed the CrystalDisk benchmark and speeds were back up to around 211 MB/s read and 139 MB/s write which seemed back to normal speeds.

I also tried copying a large file to the drive before and after secureerase in Windows 10 and before I was getting around 3-5MB/s write speeds, afterwards the drive was copying at around 95MB/s for about 10 mins (the time it took the transfer to complete) which seemed about right as I was copying from HDD -> Sandisk drive.

The drive was hot afterwards but back and performing normally. All these posts about ruining the factory partition/sector size is just rubbish. The drive uses SSD flash chips but I don’t think there is a controller embedded inside to automatically perform TRIM commands or do wear levelling, which is why the drive will slow down over time with use.

Maybe a majority of users who rarely use the drive to copy large files won’t see an issue, but if you use the drive too much it will slow down significantly.


Hi ! 

I’ve just formated my drive with the Windows tool in exFat (see screenshot below) and I got the same speed as you.



Hi ! 

I’ve just formated my drive with the Windows tool in exFat (see screenshot below) and I got the same speed as you.