SanDisk Dashboard totally blank display

Just installed the latest Dashboard version on my i3 laptop with a new clean install of Windows 10 including all updated drivers. When I start Dashboard, its window is totally blank. I’ve deleted and reinstalled as Administrator and same result. How to fix?

Dashboard 3.0.2.37 has a command line option “-disable-gpu” which can be added to the shortcut on the desktop and may help resolve your issue. This will change how the application draws itself with GPU acceleration or without, it does not affect your system GPU in any way.

The way to add the command line to a shortcut in Windows is as follows:
Right click the icon on your Desktop, then click Properties, then click Shortcut Tab, then you can add -disable-gpu text to the Target field after the path to the executable.

Hopefully that will resolve your issue. If not, customer support may be able to help.

Thanks @LostLinuxGuy, I had high hopes for that tip, but unfortunately it didn’t work :pleading_face:. Turns out that it will run in Safe Mode, but there’s no internet so it can’t check for updated firmware. I can’t imagine what is blocking it in “regular” (non Safe Mode), since this is a fresh clean install with almost no additional software added :thinking:

I just updated to the most recent dashboard and the display is a blank window. Tried -disable-gpu, no difference. It was working fine before the update. I was looking for information on my current SSD because my intent was to increase to a 2TB SSD but this doesn’t bode well for SanDisk as a supplier. Hope someone finds the solution before I run out of room on my 1TB SandDisk SSD.

Sorry you’re afflicted too @garycoryer, but it’s good to know that I’m not the only one. I had tried to uninstall Dashboard and install an earlier version, but that doesn’t seem to be possible … the installer, even one that says that it’s for an earlier version, appears to just be a stub that downloads the software to install, and it always gets the latest version.