SanDisk Cruzer Edge 64GB not working.

Hey, I used my USB for the Google Chrome OS tool since a Chrome Book OS stopepd working and needed  a USB. I packed up my USB files and removed the iso stuff from my USB using the Chrome OS tool.

However since I have done this my USB won’t show up on my PC at all…

It shows it in the Device Manger, where I have uninstalled the USB and plugged it in again, Uninstalled the USB Root Ports too.

I’ve used the Hardware and Devices troubleshoot tool it still doesn’t work. I’ve tried my USB in all front and back USB ports on my PC. Tried, using CMD to remove all partitions, cleaning the USB and to format the USB too but it just won’t show on my list at all

My PC is running Windows 10. Cannot see it in the Device list for me to click on it and add files to it etc. However tried it in a Windows 8.1 laptop and then on Windows 10 after it upgraded and it works fine just the one PC it won’t work on which I really need it to work on so I can do college work…

Is there a fix for this. I’ve tried a lot.