Sandisk Cruzer Blade 64 GB not recognizable by TV

When i first got the device, i didn’t have a problem with plugging it into our tv. I use the usb for watching movies only. However after a friend of mine downloaded several movies, i noticed that the previous movies already in the usb can no longer be opened in my computer but if i plug it in the tv , those movies will still show up. I had the same issue with my 32gb cruzer blade before and all i did was reformat it and it worked just fine but this time after reformatting this one it can no longer be detected by our tv. got an error "there is a problem connecting it to your device " or something. I tried it with a different tv but still unrecognizable. Reformatted it several times already. There’s no problem with viewing the files in a computer, just on any television i plug it in… Anyone can help please???

When the drive was new it was formatted as a superfloppy exFAT drive. ie no MBR, no partition table, and able to handle files larger than 4GB.  If the drive has been reformatted as NTFS that is probably the problem.  But with all the formating that has been performed the superfloppy format has been lost and that may be why the tv no longer recognizes the drive.

However, since it worked before you loaned it to your friend and now it doesn’t you can tell your friend you want the replacement he buys you to be 128GB. :wink: 

good luck to that… oh well… :frowning: this will still work right? not jus on tv any longer though??

Yes.  But look for an app that formats USB drives as superfloppys.  There has to be one out there.  I think Linux’s DD and FDISK commands would work.