SanDisk Cruzer Blade 16GB write protected error

ane ammapa me comoany ake unge ammalata 2paara 2paara gaane hukanna ona… mun nam kari vasalayo tamai…

what a **bleep** is this man… we are seaking something else… not repeating same thing man…

I am just one more of MANY SanDisk users who is disadvantaged by a “read-only” flash drive.   These things should be recalled and redesigned.  There are SO many complaints on this forum by now that why would ANYONE want to buy one of these things?

1 Like

Probably because less than 1% of the devices have problems.  And the 99% of the owners that don’t have problems don’t post.

Its because most of the uasers with faulty devices don’t know what to do and dont know to post in your forum. You CHEATS sandisk people.

Iam a computer parts sellerand i know how many i got returned back to my shop.

Its because most of the uasers with faulty devices don’t know what to do and dont know to post in your forum.”

A good point.  

Iam a computer parts sellerand i know how many i got returned back to my shop

How many do you sell in a month’s time and how many of those get returned?

Read that less than 1% of thiese things fail?

have had a 32gb micro sdhc for a week, suddenly came up write protected?

tried all sorts of things,

eventually by loading it into a cheap camera I formatted it.

Back into PC! Write protected! 

well I got the **bleep** thing for £10, so cheap I bought two, loaded the new, unused one in, and straight away, straight out of the box… write protected!.

less than 1% eh? and why are they so cheap? 

Thank you for posting your experience.  I’ve said all along that the problem was a Windows problem rather than a hardware problem.  If it was a hardware problem you wouldn’t have been able to format it even in an expensive camera.

Hi, I have a Cruzer and I mainly use it for my xbox 360 since I dont have that much storage on it by itself. So I put it into my computer (I dont really know why…) but when I took it out and tried to use it back for my xbox 360, when I tried to copy a file over onto it it said that it cannot do it because there is write protect on it. I dont know if this matters but I have MS Windows 7 Home Premium 32-bit. So, is it possible to get write protection off of it?

Do you have a cheap camera?  :smiley:

Referring to a poster’s comment 2 or 3 above yours.

Hi, I had the same problem and tried everything suggested but nothing worked.

Finally I found the answer was to use a Flash drive tester - in Destructive write test mode. You will lose any data not saved but you can now re-format the drive. This is the link to a free program,

Hope this helps,


1 Like

Thanks Graham.

Does the formatting remove the write protection when the drive is used back in a pc?  It was noted in another recent post that the drive could be formatted in a cheap camera but it was still write protected when put back in the pc.

Works fine on my laptop now, tried everything else including registry hacks this is the only thing that worked.

Thanks for the follow up, gdauphin.  Hopefully this helps out many of the others with problems.

How you did that? Even this software says it’s write protected. I tryed this and HD Tune Pro!!

I Just bought two 16gb sanddisk flashdrives and both of them are with this problem! I bought both on Amazon.

Hi, I am propbably 1 of the 1% who have problems with my Cruzer blade 16gb. It is also write protected on its own accord.

This happened maybe a month or so ago & I finally decided to look for a solution or if someone else has this problem. Well it seems I am not the only one.

I do believe alot of people may have this problem, but are not inclined to search the web for a solution or thinking they did something wrong.

The check flash solution did not work for me. It states the obvious: your drive is write protected, remove the write protection first.

We need some customer service & a solution to your product’s fault.

It is no use blaming Windows. It is a Sandisk problem.

Please provide a solution. I am looking forward to great customer service & a speedy solution to this problem some of us experience with your product.


pls help to remove write protect from my SanDisk Cruzer Blade 16GB,have tried all methods ,nothing is happing.

whether have to buy another drive other than SanDisk ?


nothing is happening with “SanDisk Cruzer Blade 16GB write protected error”

please suggest solution for it.

@erlo_d wrote:


We need some customer service


SanDisk Global Customer Service Contact Information

@erlo_d wrote:


It is a Sandisk problem.


Please provide a solution. 


Retrun the unit to your dealer or contact SanDisk directly via the link provided above for a warranty replacement.