SanDisk Cruzer Blade 16GB write protected error

as you can see in the pic :

this is my problem

I’m sure it’s not related to the OS I have tested in few other computers.


1 Like

i am facing same problem. i have already replaced this pen drive for 2 times but m facing same problem. what to do?

sanddisk have disappointed a lot.

products are becoming worst day by day

1 Like

Here’s what I believe happens to those who experience a “write protection error” Two weeks ago, I purchased my first Flash Drive removable disk…the SanDisk 16gb Cruzer. There is not a switch on the removable disk to over ride the write protect. 

I have the Windows Vista system installed on my Dell Inspiron lap top. When I brought the Sandisk 16gb cruzer home, I immediately placed it in one of my many usb ports. I immediately started loading “My Documents” on to the disk. It accepted them readily with no problems, all 2. something gigabytes of them. Since that time I have discovered that since the Sandisk comes already formated in the Fat32 format. I can only load 4. something gigs into it. After trying many advices from different forums I would still get the response of “This device is write protected, try again or insert a new disk” Therein lies the tale.

The following is my opinion as to why I can’t reformat my disk:  I should have (If I had known) immediately, before loading files onto it, formated it in the NTFS format then everything would be ok. I would be able to add additional files at my leasure with no problem. What I believe happens when you plug your removable drive into your machine with the SanDisk (comes with) Fat 32 in place. There is some command that automatically locks up the write protect feature of the SanDisk as soon as you remove the disk from your computer. Before I arrived at this conclusion, I tried using the suggested changes to my registry, tried formatting from the command prompt, used the disk management tool, all to no avail. That’s when I concluded that all the file tweaking on your computer won’t get the job done. It is an inherant part of the SanDisk removable disk file structure, good or bad! The only option I have from not being informed on any type of instruction is what I have tried to explain above.

In other words, “My tough luck” and 23$ not lost, but not completely satisfied with the product either. 

1 Like

@luckaduck wrote:


I immediately started loading “My Documents” on to the disk. It accepted them readily with no problems, all 2. something gigabytes of them. Since that time I have discovered that since the Sandisk comes already formated in the Fat32 format. I can only load 4. something gigs into it. After trying many advices from different forums I would still get the response of “This device is write protected, try again or insert a new disk” Therein lies the tale.

The 4GB limitation of FAT32 pertains to the maximum size of 1 file only. There should be not problems in copying multiple files totaling 4GB or over. You may want to transfer them over in smaller ‘chunks’ though, as you may or may not have enough RAM on your computer to handle such a large transfer all in one bite.

1 Like

IMO The only thing that stops/interferes with a reformat is a drive being in use.  ie A file opened on it, the drive opened in Windows Explorer, an AV locking the drive.

1 Like

I have 2gigs of ram on my dell inspiron laptop. Since I learned that—under the fat32 format—maybe I could add more files that would come close to giving me a total of 4gigs. The disk would not open up for me to accept the additional files. I keep getting the same ole, same ole—This disk is write protected, bla, bla, bla, I have gone through all of the suggested remedies and no such luck. I can read the files, copy them back to my documents- but as soon as I try to write to or make changes to existing documents—those in Microsoft Word—same reply—this disk is write protected. 

1 Like

Did someone secure it with bitlocker or winlocker?

1 Like

If that was the case, I would be told that a problem exists due to a drive being opened. close the drive and try again. It does just what I said and my disk files are healthy according to CHDSK command. I sure didn’t secure my disk. Placed new disk in usb port copied all files from my documents. removed disk checked the results…everything was fine…it showed that I had 2 point something gigs on my disk. I found some pictures that I wanted to add to those 2. something gigs the same way I installed the documents initially. That’s when I get the: This disk is write protected. I think I might purchase another one and immediately format it in the Ntfs format. I can find sandisks like mine with free shipping and only $14. That’s something I can live with. I’ll try my suggestion and let the forum know the results when I purchase another one.

1 Like

Yes, please do let us know your results.

In the interim try booting your pc into Safe mode and then try formating the Cruzer.

BTW  Does your Cruzer have U3 on it perchance?

I’m having exately the same problem, my Cruzer Edge 16GB became read-only from the nothing. 

No resolutions yet ? 

Brazilian Thanks.

“No resolutions yet?”

Have you tried writing to it after booting to Safe Mode?

Have you tried detailing what your environment is?  ie what OS are you running, Linux or Windows?  XP or 7?  32 bit or 64 bit?what other apps are you running, especially what anti-virus and anti-malware?  Are you using a personal pc or a school pc?  Schools and corporations can impose write limitations on their pcs.

If a personal pc and WIndows XP or 7 have you tried this option:

1. Open Start Menu 

2. Run, type regedit and press Enter, this will open the registry editor. 

3. Navigate to the following path: 
4. Double click the key WriteProtect in the right pane and set the value to 0 In the Value Data Box and press OK button 
5. Exit Registry 
6. Remove your Blade

7. Reboot your pc.

8. Re-connect your Blade to your pc. 

Without knowing what your running and what you’ve tried it’s hard to suggest a solution.

i’ve already did it and don’t worked for my cruzer.


and i tried programs like HS Utility repair, uRescue, but no one works with my pendrive, says pendrive not found. The same error appears at Windows XP and 7.

Just to be clear, you tried booting to Safe Mode then writing to the Cruzer?

BTW A “pendrive not found” is different from a “pendrive write protected”.  In order to be write protected the pendrive is found by the OS.

Guys please help me I’m stuck here. I really need to use my memory drive. I can’t delete or cut or format the drive. I have test it in so many computers (windows, Linux &…) Please give me a solution

please!! please!!

Friend, the utility program who should format the pendrive says pendrive not found. I can see what is on the pendrive, but i can’t format, add new files and remove files, says ‘Your pendrive is write-protected’.

I’ve tried to boot at secure mode and don’t worked. 


I’m still confused RickDan.

The utility to format the drive runs under Windows?  Or is it a standalone utility that boots from a CD or USB?  If the utility runs under Windows and Windows can read the drive it could mean that the utility doesn’t support removable drives or Windows security is preventing it from seeing the drive.

As for “I’ve tried to boot at secure mode and don’t worked.” does that mean you couldn’t boot to Safe mode or you booted to it and the format utility didn’t work.

Another option might be to try a utility like Parted Magic to format the drive or at least see if it can write to the drive.  If it can write to the drive the problem is Windows.  If it can’t the problem is the drive.


I have the same error on my 8 gb cruzer edge and tried 2 format it with windows(7,xp)linux(debian,ubuntu,redhat) and tools like Gparted…, but no use… In linux it can be mounted only as a ‘read only file system’…Wasted so many days trying to fix it…:frowning:

Any help would be greatly appreciated

Thanking You


guys there is really no way of fixing this ive tried everything from fileshredding to uninstalling the only thing you can do is probably call sandisk and see if they can send you one or you can ask you to wipe yours it may cost you unless you have a warranty on it but thats what i di and there gonna send me one around 2 weeks :cry:

Who posts to a USB Flash Drive forum? I just registered to join in the fun. How many of these do people get through? Anyway it’s loquacious & erudite, so.

I think luckaduck’s right for the wrong reason. Fat32, Dell, Vista, forget it. The drive will store the data it says, less a small amount for who knows why. Here it is: the drive has two write caching policies : (a) pull it out quick; (b) ask Windows to let you pull it out. Default is “Ask Windows” - see that little green tick thing in the System Tray? (If you don’t believe me, go Computer>F-drive>Properties>Hardware>Sandisk Cruzer Blade Device>Properties>Policies). So, that’s how it is, you forget to ask permissionle, pull it out (you might as well marry the thing), no green tick, it says"No way" and uses write protect to stop your barbarity.

Try this: Computer>F-drive (or whatever - call it Mabel if you want)>Properties>Sharing>Advanced Sharing>Share this folder>Permissions>Everyone>Full Control>Apply>OK>Apply>OK (it’s a different box)>Close. Then ask Windows to let you take it out. Then: in Windows run a mega-destructor data erasure program like East Tec or Cyber Scrub (hint: 15 day free trial). When you’re done, leave it for a while, then stick the drive back in, and - yes? No? If the mofo can remember it’s write- protected after your whole system’s been East Tec-ed, it’s more human than I am.

I can’t promise it’ll work, but I’ve done it, and it’s worth a go.

The weird stuff people want you to do - I’m surprised nobody wants to stick a needle in the hole and get at the little write protect man.

Don’t format, don’t mess about with drive recovery programs, and DON’T BLAME THE PRODUCT!

Good luck