SanDisk Cruzer Blade 16GB write protected error

this is a serious issue. This is not the first sanDisk product that has turned to ****. You guys must provide a solution rather than blaming windows

1 Like

It is definitely a hardware glitch. tried everythng in the forum and still no use. SanDisk should own up to their fault rather than make excuses. Stop wasting our time, by blaming the OS.

I understand your frustration.

It has been my experience where I had a SanDisk USB stick that worked fine in one Win 7 pc be classified as unwritable in another Win 7 pc.  Putting it back in the 1st pc and it was writable just like before.  I got it to work in the 2nd pc my changing the Win 7 Sharing options for it to Read/Write and adding the Everyone user id to it.  SOME write protect / Read Only problems are Windows 7 related.  But I agree, not all of them seem to be.

I have a 16gb cruzer that shows as Write protected on a windows XP System. it has never been in a windows 7 system. I have tried EVERYTHING I can find for the the last 2 Weeks…when i have time to work on this… This is the second drive that has done this on 2 different OS’s This is a hardware issue not a OS issue.

I would expect that Sandisk could post a solution, a utility or provide replacments…this seem to be a wide spread problem. I expect that sandisk would be concerned and DO SOMT?HI?NG! about the problem.

My 4 GB sandisk flash disk is write protected and I can do nothing about it!

Tried formatting it by different programs and nothing happened.

Whenever I try delete any file from it it says it’s write protected. remove protection.

Is there any solution?

I’ve got this exact drive - 16GB Cruzer Blade, and it’s gone write protected.  I tried it out in my new Raspberry Pi which i think may have had a bit of a USB driver issue - so I guess it’s gone into some kind of safe mode.

Anyhow it’s definitely broken - shows up as Read Only in Disk Utility in OS X, and that won’t let me format or repartition or anything.

Any chance that someone from sandisk could tell me whether the device is beyond repair, or if there’s some tool that could make it work again?

if it is write protect it will need to be replaced. contact sandisk support to check warranty status. 

Changing the registry entry WriteProtect from 1 to 0 solved my problem on a Windows XP PC! It was working fine on my MacBook and Win7 laptops, but not on the particular Windows XP PC I used today.

Interesting.  So this was a WINDOWS problem.  hmmmm  what a surprise.

The question is HOW did the Write Protect switch get turned on.

There are a lot of reports of write protection being turned on, on Windows 7 systems, Windows XP systems and etc.  Some may indeed be problems with the SanDisk device but I believe some are caused by other factors.  In some cases the USB drive may have been  used in a game or a car and etc prior to the problem.  Or a USB hub with insufficient power or a pc that experiences a power surge.  Or a inadvertent click on a mouse pad at the wrong time.  


Are you serious that you, as an ‘expert’ still think that it is a Windows problem? I have the same issue only from a few days ago, but I have read several topics and tried all the suggested solutions with no success, so it is clear that it is a HARDWARE ISSUE FROM SANDISK!!!

So you are either not an expert or you’ve got the instructions from your management that you need to blame the people or Windows, etc.

Many people can’t return the product for replacement since it contains already sensitive data which can’t be deleted due to the  hardware issue , but readable.

And you know, it is very interesting that SanDisk dramatically reduced the price of these drives recently. So it seems that by now it is clear for everyone including SanDisk that the products are bad , and no real solution exists to this problem, so SanDisk is trying to get read of the bad products quickly.

You know it is very sad, but hopefully people will ‘appreciate’ it long term… With this reacton, SanDisk is a failed brand…

I ment SanDisk is trying to get rid of the  bad products  quickly…

Are you serious that you, as an ‘expert’ still think that it is a Windows problem?”

In SOME cases yes.  I have experienced the problem on a Windows 7 system and resolved it by changing a Windows 7 settings.  The above poster resolved the problem on an XP system by changing a Windows XP setting.  Hardware problems don’t get fixed with Windows setting changes.  So in SOME cases the problem is a Windows problem.  And in SOME cases it appears to be a hardware problem.

As for the cause of the latter it’s hard to say.  Low voltage, high voltage, heat, etc all may play a role.  A manufacturing problem would seem to be something that would show up as soon as the drive is plugged in but that’s never what’s been reported.  It’s always after the drive has been used or being used.


I did not say there could not be similar issues caused by Windows, but now it is not the case. You should already realized this fact. This topic has had already 10000+ visitors, who look for keywords ‘USB’ ‘Sandisk’ ‘write protection’, etc.

It is not a coincidence.

I think most of us have already tried ideas (from other forums), like device properties settings in Win, USB virus scan, DOS prompt, low level formatting, registry change, etc.


In my case it was purely Win XP 32 bit (on 3 different PCs). I have not only my Sandisk Cruzer Blade, but 5-6 other type and brand of USB drives which I use frequently for years now. On these PCs the newly bought Blage 16GB got write protected after 2 months. Looking at the forums, many people has this issue where the above mentioned methods do not solve the problem.

Again there are cases even with Sandisk when these methods can help, but it is the minority. By now thousands of Sandisk users have this write protection error, when nothing can help so far… This clearly indicates a manufacturing / design issue at your site. When I say hardware, of course it could be firmware as well, but definitely something with the flash drive. These products are faulty. And you are selling them quickly very cheap… DISREPUTABLE!!!

Dear All who are suffering from write protection error,

The customer service answered to me and they know about the issue, so here it is to clarify the situation to everyone:

"I understand that you are getting write protection error while accessing your Cruzer flash drive. The flash drive has detected a potential fault and has become write protected to prevent data loss. There is no method to fix this. You will need to backup your data and replace the flash drive.

Our team of developers is in combination with the OS developers looking into a solution to resolve this issue.

Please note that only a minor percentage of users are experiencing the write protection issue and these are the customers posting on the internet to find a solution."

So wait, or change back your drive if it’s under warranty…

1 Like

"Our team of developers is in combination with the OS developers "

OS developers??  If the problem is a hardware problem why would there need to be discussions with OS developers??  hmmmm…

Thank you.  :laughing:

1 Like


Are you serious? The key here is:

The flash drive has detected a potential fault and has become write protected to prevent data loss. There is no method to fix this. You will need to backup your data and replace the flash drive.

This is an official answer from SanDisk. Obviously it is a hardware problem…

The OS developers may find a trick, but it is less likely… Flash drives needs to be replaced as written…

1 Like

There is no software solution!!! Its a hardware fault!! I use this kind of device to backup important data!!! SanDisk is not a serious company!!! BUY KINGSTON memory!! never buy SanDisk produtcts! !!!  Cheng Brazil


I’ve had three of these usb drives lock up saying they were right protected (2 )16gig and (1) 8 gig.  the two 16 gig drive were very new, was only able to use a gig of memory before they became locked…these are not isolated incidents…Sandisk drives have big problems will never buy another one!


What a story I bought 2 SanDisk cruzer blade 4g flask drives, If you tell me that your team can do nothing to resolve the failure off your disk then they should go and developed something else, to me SanDisk is then a waste of time and money, or is this build in errors to up sales 15%, this boring excuse is not the space worth, do you really think your customers are peanuts in a packet, do you really think we must buy the storey of it is limited to people posting it on the net, someone should wake up and do their work, resolve the problem, my first SanDisk products was the last two.

Thanks for the nothing

Nickey Matthee


I was hoping to see a solution by this time instead of the mind boggling jumble that leads to nowhere!

1 Like