SanDisk Cruzer Blade 16GB write protected error

Hi Tapeworm. Many thanks for your response. Is there no other possible way to copy the complete 5GB file onto the flashdrive? 

Once again, Thank you.

Oh well I can honestly say this is not a microsoft proble!  I was happily using a SANDISB cruzer Edge 16GB on a mac and a linux box.  Always ejecting(sic) the stick before removing.  For some reason best known to the stick it went read-only on the middle of a multi file transfer. I have been unable to write to, format or partition the disk since.  How do I get a replacement for this product?  This thread has had over 7000 views so it’s not an isolated case.

@cedric wrote:

Hi Tapeworm. Many thanks for your response. Is there no other possible way to copy the complete 5GB file onto the flashdrive? 

You could re-format the drive to NTFS (same as computer’s hard drive) and that would allow the 5GB file to be transferred. However, there is a reason why all portable flash-based thumb drives are formatted to FAT32. It simply works better for the majority of people.

Try it and see. You can always format it back to FAT32 if you want to.

I have gone through Windows XP, Windows 7, and multiple versions of Linux to see if any were able to solve my issue through basic settings manager, through command prompt, and even going as far as re-partitioning the drive, but every last option is denied because of the write protection error. If there is any solution to this, please help!!!

If you figure it out please report back.

The only time I’ve encountered it it was a Windows 7 Sharing option set to Read Only.  An easy problem to fix.  But when it carries over difference OSs it’s a different problem and no idea as to the solution, or the cause.  

>The only time I’ve encountered it it was a Windows 7 Sharing option set to Read Only.  An easy problem to fix. 

>But when it carries over difference OSs it’s a different problem and no idea as to the solution, or the cause.

My 16GB SanDisk Cruzer locked up (going into “write protected” mode) in the middle of a large file copy.  I have XP

and the flash drive has never been hooked up to a Windows 7 system.

I’m guessing that this is some sort of hardware glitch that SanDisk doesn’t want to admit to for some reason, probably because they don’t have a fix for it and/or don’t know exactly what is causing it.

" I’m guessing that this is some sort of hardware glitch"

While I suppose it’s possible I’m still leaning toward a software problem.  A virus maybe, or even a Microsoft update.

A file can become Read Only via an Attrib setting in Windows Properties, a DOS command, or a Windows 7 Sharing function.  Not being able to format the drive brings it to a different level.  Maybe a Windows function like a Recycle bin or System Restore folder is in use by the system or a bug in a anti-malware app has it open.  If the problem carries over to a different OS then it gets more convoluted.  Maybe the FAT got screwed up.  But the error falls back onto the OS that caused it. 

Looks like there are a quite number of issues about the Write Protected Error. Is this considered to be an ongoing issue? 

I hope not. 

Gee, according to your other posting it’s being worked on and a solution is coming soon.

Are you trolling here?

Same issue here - brand new SanDisk 32GB USB stick, now being reported by

both windows and two linux systems as being write protected.

Tried using the low-level partition tool fdisk on both linux systems to wipe the partition table,

and even that low-level tool was telling me that the partition table on the stick

is non-writable/non-updateable.

Sorry, but at this level it’s not your choice of OS or any of its particular foibles - it’s

the chipset in the USB stick…

So now I have a USB stick that I want to return  for a refund/replacement, but

unfortunately it has a lot of files already on it from my fathers PC, some of which

contain sensitive personal data.  So I’ve got NO WAY to securely erase this friggin

thing before I send it back for refund(where it will pass through -how many- hands)?

I’d take a hammer to it, but then I won’t get a refund.  I’m between a rock and a hard

place, thanks to SanDisk.

I’ll be extremely angry if this was a known hardware flaw, and SanDisk failed to

do a proper recall after they’d found out.  How many lots of these defective

beasts have they continued to sell?

I think it’s time for a class-action suit.

What a joke.

Halfway through a copy the 8GB Cruzer gave me the ‘write protected’ error.

Lots of posts about this. Was supposed to have 6GB of data on its way to the US (lots of files under a gig each so its not the 4GB limit problem) … there is no way to circumvent this problem … I’ve wasted money and hours and hours on this thing … now I have private data on a Cruzer that I can’t delete … and I want my money back and compensation for my time.

I have tried everything even the DiskPart command line functions … using DiskPart I switched to Volume 11 which was the Cruzer (I have a lot of drives connected to my machine) … even DiskPart came back with a ‘This disk is write protected’ message!

Purchased a Lexar 8GB flash drive … copied the files in no time at all … no errors. DO NOT BUY SANDISK.

Darren Powell

Sydney Australia

this is a serious issue. This is not the first sanDisk product that has turned to ****. You guys must provide a solution rather than blaming windows

1 Like

It is definitely a hardware glitch. tried everythng in the forum and still no use. SanDisk should own up to their fault rather than make excuses. Stop wasting our time, by blaming the OS.

I understand your frustration.

It has been my experience where I had a SanDisk USB stick that worked fine in one Win 7 pc be classified as unwritable in another Win 7 pc.  Putting it back in the 1st pc and it was writable just like before.  I got it to work in the 2nd pc my changing the Win 7 Sharing options for it to Read/Write and adding the Everyone user id to it.  SOME write protect / Read Only problems are Windows 7 related.  But I agree, not all of them seem to be.

I have a 16gb cruzer that shows as Write protected on a windows XP System. it has never been in a windows 7 system. I have tried EVERYTHING I can find for the the last 2 Weeks…when i have time to work on this… This is the second drive that has done this on 2 different OS’s This is a hardware issue not a OS issue.

I would expect that Sandisk could post a solution, a utility or provide replacments…this seem to be a wide spread problem. I expect that sandisk would be concerned and DO SOMT?HI?NG! about the problem.

My 4 GB sandisk flash disk is write protected and I can do nothing about it!

Tried formatting it by different programs and nothing happened.

Whenever I try delete any file from it it says it’s write protected. remove protection.

Is there any solution?

I’ve got this exact drive - 16GB Cruzer Blade, and it’s gone write protected.  I tried it out in my new Raspberry Pi which i think may have had a bit of a USB driver issue - so I guess it’s gone into some kind of safe mode.

Anyhow it’s definitely broken - shows up as Read Only in Disk Utility in OS X, and that won’t let me format or repartition or anything.

Any chance that someone from sandisk could tell me whether the device is beyond repair, or if there’s some tool that could make it work again?

if it is write protect it will need to be replaced. contact sandisk support to check warranty status. 

Changing the registry entry WriteProtect from 1 to 0 solved my problem on a Windows XP PC! It was working fine on my MacBook and Win7 laptops, but not on the particular Windows XP PC I used today.

Interesting.  So this was a WINDOWS problem.  hmmmm  what a surprise.

The question is HOW did the Write Protect switch get turned on.

There are a lot of reports of write protection being turned on, on Windows 7 systems, Windows XP systems and etc.  Some may indeed be problems with the SanDisk device but I believe some are caused by other factors.  In some cases the USB drive may have been  used in a game or a car and etc prior to the problem.  Or a USB hub with insufficient power or a pc that experiences a power surge.  Or a inadvertent click on a mouse pad at the wrong time.