SanDisk Cruzer Blade 16GB write protected error

I have the same issue as many of you. When I posted the problem to Sandisk technical support I received the following reply:

"… Thanks for emailing SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.

I understand that you are getting write protection error while accessing your 16GB Cruzer Blade drive. This is because the flash drive has detected a potential fault and became write-protected to prevent data loss. There is no method to fix this, you will need to back-up your data and replace the flash drive; we do apologize for this inconvenience… "

Followed by procedure to return under guarantee. So now we know for sure that the problem can not be resolved.

Amigos, tenho buscado uma solução pro pendrive sandisk cruzerblade de 8 gb que comprei, salvei 408 mb de dados, e só, não consigo salvar mais nada nele, nem formatar, nem apagar separado, nem pelo prompt, nem uma série de coisas que tentei, no xp, no windows 7, no linux… O detalhe é que sempre compro KINGSTON,  e nunca tive problemas, foi pular pra essa marca vagabunda e veio esse problema. se alguém tiver uma solução, manda uma luz aí…

E DESDE JÁ DIGO, NÃO NÃO NÃO COMPREM NADA DA SANDISK!!!

No hablo alemán aquí. :wink:

I have a cruzer pop 16GB for three weeks and i had used it only once i have saved some and some movies and after i access it the second time it’s already “write protected” which i can access the file within the usb but i can’t delete and add files and i can’t even format my usb i have used many kind of usb and i have never encountered this kind of error. my OS is windows vista i had already tried it to different computer but it always the same error. i have done all the remedies posted in the net but still nothing and i have read a thread that sandisk already know this defects in their usb and my question is why is it still being sold in the market and they even said that sandisk said there are still no remedy and just “replace” the usb wtf. how can a company sell crap and just get away with people money? I was really interested buying it because i saw it was very cheap compared to my earlier sony usb that is still working i should have trusted a brand that i know i can depend on

@wtfson wrote:

 

I was really interested buying it because i saw it was very cheap compared to my earlier sony usb that is still working

There you go. Less money does not necessarily mean value. Or to put it another way, you get what you pay for. :wink:

1 Like

Hi the write protection isnt related to 64bit windows I have tried the drive on 3 different pc’s win7 64 and 32bit and win XP and it is write protected on all of them, I havent had this problem before and am glad I found out about it now as I was intending buying a scandisk SSD this week but this issue has made me rethink so will go for a Samsung instead.

Quantity rather than quality might make the company money in the short term but long term it will only hurt them as consumers like us will move to other suppliers.

I always thought Scandisk was a decent product and have used them in the past without problems, I have another Cruzer blade which I am now waiting for it to crap its self, Yep your right u get what u pay for :confounded:

1 Like

If you have reviewed the posts here you know that SanDisk has a long warrantee and has replaced all drives that people have had this write protect problem with, free of charge.  So yes, they do have a problem but they also replace all drives with the problem.

http://kb.sandisk.com/app/answers/detail/a_id/5232/~/return-material-authorization-(rma)-process

yep we have read the posts and know that Scandisk have replaced the drives under warranty and that’s all good however the drives that they replace them with still have the inherent problem of write protected error, with all the posts here it seems that the problem isn’t an isolated one so one would be stupid to keep using the same product knowing that it has a problem and may have to be replaced at any time not to mention the inconvenience of having to send it back for replacement or taking the drive somewhere to copy data to it to find that it wont work, you would have to take a backup drive with you just in case

No one has ever reported a replacement from SanDisk having the problem again.

The problem appears to have been a manufacturing problem of a batch rather than a design problem.

if i buy any local company Usb it is better than Sandisk…i use it few month and it is givig error write protected…send me solution

http://forums.sandisk.com/t5/All-SanDisk-USB-Flash-Drives/HOW-TO-REMOVE-WRITE-PROTECTION-FROM-USB-FLASH-DRIVE/m-p/289884/highlight/true#M4035

Hi,

I want to know about how to remove write-protection from my san disk 4GB pen drive…

I want the permanent solution for that…

Click on the link in the post directly above yours and follow the advice given.

I know this is an old thread, no fix sill…

Clearly a firmware problem, these devices contain an internal soft switch, only the manufacturer can reset, sandisk is unwilling to help, they could release tool to reset to default.but this way they sell more instead of reset…

Or an electrical problem, like a chip or circuit burned out. 

And since SanDisk provides a free replacement including shipping how are they selling more???

You’re not a business major are you. :smileyvery-happy:

m having the same problem :confounded: what to doo

same solution

http://forums.sandisk.com/t5/All-SanDisk-USB-Flash-Drives/HOW-TO-REMOVE-WRITE-PROTECTION-FROM-USB-FLASH-DRIVE/m-p/289884/highlight/true#M4035

انا الفلاشة بتعتي محمية ومش عيزة تتفرمت اية الحل

@medoessam wrote:

انا الفلاشة بتعتي محمية ومش عيزة تتفرمت اية الحل

This really isn’t the place for religious or political commentary. And if this is some attempt at covert communication between those planning terrorist attacks or other nefarious activities, it has been reported.

Ok.

I have this same problem with my Cruze Glide 32GB.  I hate to say it, I think it IS the product.  It’s certainly not a result of removing the drive (in my case)  To wit:

I formated the drive to NTFS this morning.  No particular reason, other than I’m more comfortable with it.  Then, I copied some 10G of data onto it.  (music, if you must know).  I had to take a breake for a few hours ( about 7 ) then went back to that laptop to finish copying.  Drive was still in the port, computer was still on (no indication that it had re-powered in my absence). I attempted to add more files, and was immediately greeted with the “disk is write protected” message.

Since then, I’ve tried a zillion reformat / shred / you name it applications.  I’ve dinked with the registry.  I’ve tried the drive on multiple systems - both physical and operating -  each and every system declares the drive as write protected.  Ergo, it’s something on the drive.

And, so far, I’ve found exactly zilch that would let me modify any write protect scheme on the drive itself - everything is pointed at working through the O/S.  Not a lot of help, in this instance.