Sandisk cruzer 16GB became read-only.

I do not except that the " Oh you should have formatted it in NTFS when you first got it”"

I agree, but there’s a lot of kids who think it’s the thing to do.  1.  FAT32 is a more universal format for multiple machines.  2. FAT32 has less overhead then NTFS thus providing longer life for the USB device.  However, if you need to store files larger than 4GB, usually image backups and some movies, then NTFS is your only answer.

This  is a forum that the manfacturers benefit from I do not wish to be rude to any members of the public , but why should you volunteer your time just because there to tight to emply a help desk.”

Some of us are techs who like helping other people.  As a former network Engineer you should be able to relate to that.

so this is to SAndisk - Why does your product not work

As a former network Engineer you should know that s**t happens, and it’s only possible to resolve if you know: what happened, how it happened, when it happened, where it happened, who was involved, etc.  And as you read these various reports that information is rarely provided.  All that is posted is “my device doesn’t work”.  And as a former network Engineer you know that the quickest way to resolve a problem machine is to replace it.

why does it not tell you to format it in NTFS, or better still why do you not do it in the factory?”

See my narrative above.  And NTFS won’t solve the problem.  Highly unlikely the problem is in the file system.

“_ what is the solution to this problem ?”_

Replace the device.  Either from where you bought it or from SanDisk.

You are absolutly right here.

I just bought a new SanDisk 16GB and put some files on it. I got an error during copy because one of my files is > 4GB.

Sure I thought, it’s FAT32, so reformat and copy again finding out that the filesystem is now READONLY!!

So copy a file > 4GB on a sandisk and it locks up the whole disk making it totally unusable.

THANKS SANDISK, CRAP!!!

My pendrive of sandisk has become readonly so i want to know how to contact with the company?

" i want to know how to contact with the company?"

http://kb.sandisk.com/app/answers/detail/a_id/5232/~/return-material-authorization-(rma)-process

SacanDisk has software on the Flash Drive that changes it to a Read Only if the Drive senses something is wrong with the Oerating System. I received a replacement ScanDisk Cruz 32 GB from ScanDisk. The first thing I did was reformat the ThunDrive to NTFS so I can save fiels larger than 4 GB as 1 file and delete the ScanDisk software that can create the Read Only.

Scandisk has software on the Flash Drive that changes it to a Read Only if the Drive senses something is wrong with the Operating System. I received a replacement Scandisk Cruz 32 GB from Scandisk. The first thing I did was reformat the Thumb Drive to NTFS so I can save files larger than 4 GB as 1 file and delete the Scandisk software that can create the Read Only.

FWIW  The SanDisk software does not create the read only condition.  If software could create the condition than software could remove it and it can’t be done.

hello,
I read that there is an issue with the NTFS format in the USB sinse 2013, now (2016) I have the same issue and there is no a known solution for it, so, I would like to know if you already have any solution? or how can I get in contact with you for the refund solution? that because there is no a SanDisk in my country (Colombia south America).

my issue is that I am not able to change the “read-only statatus” to my USB, so I can’t save files on it or format or any admin task, in other words my USB is completly useless.

There is no refund but there is the possibility of a replacement.  Go to this link: http://kb.sandisk.com/app/answers/detail/a_id/5232/~/return-material-authorization-(rma)-process

Be sure to copy your files off the drive before returning it.

This works - https://www.sdcard.org/downloads/formatter_4/index.html

THERE IS NOW A FIX!! :smiley: I found a way to bypass it in Ubuntu, mine went into Read Only Mode too. For a while, I had to play around with it. I found several solutions.

On Ubuntu you can use the cp or mv command to copy via command line, if that doesnt work (it worked for me) then you can try this…

Go into Disk Usage Analyzer which is a built in program on Ubuntu, then click on the drive… you will then see a trash folder… delete all the files in the trash bin. Once I got rid of all those files, it was finally able to copy and paste again normally.

hi,

I have a 16GB cruzer, that’s about 8 months old, it just became read-only.
There’s no way of putting it back in read-write with windows and if i try formatting it, it says the device is readonly too.

What can i do? Is the drive broken?

Thanks

Backup your files and return it.  The RMA link is posted above.

As the drive is now read only it is not possible to wipe the data before returning it.

I don’t want to send SanDisk a drive with my personal data on it.

So how do I get a refund/replacement ?

When you talk to SanDisk on the RMA mention your concerns.  In the past they have allowed such users to smash the drive before returning it. 

Got dammit it’s 2020 and I can’t believe Sandisk has still not resolved this issue. Been like 8-9 years lmao.

For more context I also bought a sandisk (ultra) usb (3.0) drive with 32gb of space for like 27 euro about 2 weeks ago for its high speed writing/reading speed for school purposes (also to eventually store a few games), and as you might guess I came into the same situation as this guy here where the usb suddenly turns into the write-protected mode.

The worst part is I have no idea where did put my ticket (as proof of purchase) and the only thing what I have left is the broken?/unusable usb and the back of the package with some sort of free software recovery license (like if they have predicted my drive would break and I’d need it lol :unamused:) that I kept just in case if someone I knew would have an use for it, …which I’m not even sure at this point if I can use this as proof of purchase.

I’m still kind of disappointed of this product because they leave you no option other than sending back the usb and wait ages before they send it back. A hard reset switch/button would be a good idea in case its just a false-positive or something so you can still use your drive in the meanwhile. (BTW I formatted it to NTFS the first day when I got it so pls people don’t blame me for using FAT32 which I am not)

NTFS was your 1st mistake. It adds extra writes to the drive. exFAT would have been a better choice if the drive wasn’t already formatted with that.

If you purchased the drive using a credit card you should be able to return it to the store for a replacement. They can verify your purchase on their system via your credit card number.

Yeah never used exFAT before and didn’t have any reasons too, didn’t know about that one though “NTFS adds extra writes to the drive”.
Anyway not sure why does that matter since the drive is like 2 weeks old and it wouldn’t make a huge difference by now.

Also I think I might have paid using a credit card but unfortunately not sure if the store policies would allow to get a replacement without the ticket. (at least in France where I live)

You won’t know until you try. Good luck and stay safe.

Yeah had this issue with my 8GB Cruzer, had to request an RMA for a replacement, I tried multiple Linux tools, Windows, etc… Drive just wouldn’t remove read-only. It’s hardware failure typically and the only fix that works is getting the drive replaced. I would suggest opening an RMA for replacement.

Register the product
then
Request RMA.