SanDisk Clip Sport Firmware 1.38 released

After what seems like two succesful upgrades my info tab still tells me that the Version is 1.36.

Is there another way to check if the uppgrade was succesful?(differences between 1.36 and 1.38?)

The ugrade files 1.36 and 1.38 apears to identical in size.

The upgrade files 1.36 and 1.38 apears to be identical in size.

I think the link to Firmware 1.38 refers to version 1.36

I think this edit links to version 1.38…


Okay, as soon as someone know, I will try again.

Not willing to brick hardware due to undecided info.

1 Like

I’m disappointed. Still no way to add an album at a time to a Go List. For the next firmware, in the drop down menu from the now playing screen, I want a choice directly below the add song to Go List. I want a choice add album containing song to a Go List. 

I downloaded and installed the release (from and confirmed that the version is 1.38. I’ve noticed no differences in behavior.

this volume hearing damaging message is getting on my nerves.

im listening to vinyl rips and old recordings from 1995-2005, those are quite silent compared to the **bleep** release now, so im always facing this stupid message.

any way to turn it off?

if not im reverting back to 1.36 or is there a version 1.37?

everything else works great with this version.

I tried to install this firmware over version 1.17 (installed on player I just purchased).  After I disconnected from the computed, the player went through the install, apparently successfully, and shut itself down.  When I restarted it, it just displays “SanDisk” and freezes.  Trying to reset by holding the power button for 20+ seconds causes the screen to go dark, but as soon as I release it, the player turns on and displays “SanDisk” again.

What do I do now?

Here are a few comments and suggestions.

Normally, the Clip Sport can be turned On (or Off) by holding down on the Power/Select button for 3 sec (and then let go).

    (Make sure your device has at least 10-20% charge. Try connecting to an A/C charger via USB.)

  1. Maybe eject your micro SD card and then see if your Clip Sport starts normally.

  2. Maybe try connecting your Clip Sport to your PC,

      If your device connects normally, try reapplying the Firmware file (should be named upgrade.hex)

  1. Maybe try applying the previous working version of the Clip Sport Firmware (1.36).
           I think the previous version (1.36) is still available at this link

Please write back and let us know your progress.

1 Like

Thanks for the reply.  This is what I get trying the suggestions.

The normal 3-second shutdown does nothing at all.  Just keeps displaying the word “SanDisk”.

Device was fully charged when I started the upgrade.  Using an A/C charger doesn’t appear to do anything - no “Charging” message on screen, just the “SanDisk”.

I don’t have a MicroSD card in it.  (Haven’t gotten it to actually work properly with tracks on internal memory yet, so no point to adding more.)

It does not connect normally.  Apparently it is in a state where USB doesn’t work, as /var/log/messages doesn’t record any device connect info when I plug it in.  Therefore I can’t apply the older firmware.

Only thing I can think of from here is to let the battery discharge completely…

Really sorry to read your continuing problems.

I think it will not help to let your Clip Sport battery completely discharge.  Are you able to shut it down by a 20+ sec press of the Power/Select button ??

I can only think of one more solution.

(If your player has discharged by the time you read this suggestion, try connecting to a 1.0 amp charging block using the original micro USB cable.)

Hold down on the Back button (aka Lock button) and the Power/Select button at the same time for 30 secs or longer??  Then see if the player comes on with a normal 3 sec press.

Beyond this advice, I fear there was a problem with your attempt to install Firmware 1.38. I have not tried this version on my Clip Sport (still using 1.28). Make sure your upgrade.hex file has the filesize 28,491 kb.

Hopefully, a few senior SanDisk Forum members will provide more useful advice for you??

The 20 second press does shut it down, but it restarts and displays “SanDisk” immediately after I release the button.

Back + power shuts it down after about 7 seconds, but again, it immediately restarts to “SanDisk” when I release the buttons.  (Not sure about the amp rating of the charger, but it’s the one I use for other devices.)

After apparently running the battery down, plugging it into a USB socket causes the “SanDisk” screen to appear, but nothing further.  Seems that there’s no charging, as it goes dark when unplugged.

Really sorry.  This is bad news.

Are you able to return your player for refund or exchange?

I don’t know if it’s returnable, but it was only like $40 so probably not worth the hassle.  Thanks for trying to help, though.

I would like to know if there are any reasonably decent replacement players, though.  By “decent” I mean something that straight out of the box will not treat my audio files as “songs” that can be played in random order. but as tracks that are generally integral parts of a larger work.  It was a bit disconcerting when I loaded a few things on this, and got Act 3, scene ii of “A Midsummer Night’s Dream” followed by one movement of a Brandenburg Concerto, then a bit of Mussorgsky…

Maybe explore features of the iPod Nano & iTunes management software?

And, maybe spend a few minutes reading the Apple iPod Nano User Forum to read about any nagging problems?

I am still learning to optimize my enjoyment of the features of my Clip Sport(s). Although this device is designed for a modest selling price, it has a few modes of convenient & pleasant audio playback and the big advantage of removable micro SD cards.

I think most user play order requirements can be readily resolved using Playlists (batch file or software) and using FAT sorting software. A few dedicated users are willing to invest extra effort to curate their ID3 tags for optimum  enjoyment.

Thanks for the suggestion.  I apologize for not including “Not an Apple Product” in the question - I tend to take that too much for granted :slight_smile:

The problem with creating (M3U) playlists is that it seems much too complex a process, at least from the little research I did before the “upgrade”.  I’d have to write something to scan the tracks  for things like running time in seconds.  And ID3 tags really don’t seem meaningful for anything other than popular music.

I have the same problem as jamessqf. I tried to update the firmware to 1.38 and my player is not turning on anymore! I just got the Sandisk logo and it turns back off. I tried on 2 different PCs and it is not even detected by Windows. I tried every tricks on the book, it just shows the Sandisk logo and then blank screen.

I am angry because Newegg won’t give me a refund, only a replacement. :angry:

Reply to users NALF and jamesqf:

I tried using The Google to search for advice how to recover from the nasty problem of “Stuck on Flower Boot Screen”.

I found this suggestion from user Saratoga on the Rockbox user forum in March 2014.

Sounds like the file system is corrupt.  The bootloader has a failsafe USB mode that shouldn’t care about that.  Turn off the player, hold down the select button, then plug in USB.  It should then mount in Windows (the player itself will have a black screen).  Check the disk for errors, fix any that appear.  Probably then everything will work.

Please report back here with your results and comments ???