Sandisk Clip 2GB not recharging or connecting.

Had a sandisk sansa clip 2gb for 3 months now without any problems. But now it won’t recharge or connect to the computer. 

When i try to connect it, it turns on for a second then turns off again and not recharging at all.  

Have tried to soft reset it, but it did it not help. 

Unfortunantly its not possible for me to return it… 

Anyone have any good ideas on how to solve this, or are the player beyond help ?

Can you try to force an MSC mode connection?  Clip off and placed into hold (on button all the way down), hold the center button down when connecting the Clip to your computer.

I’m having the exact problems as Margorita with my 4gb Clip.  Attempt to solve forcing MSC mode did not work.  This all happended after plugging in to a USB port to recharge and add some additional songs.  The screen went blank during the process.  I tried resetting and get the a “refresh database” phase and then everything shuts down again.

If you can’t get the computer to even recognize the device, how can some of the fixes even be attempted?

I am having similar problems with 2GB SanDisk Sansa Clip.  The devise is not being recognized by the computer, thus I can’t do an error check.  The screen displays only  SanDisk sansa.  Yesterday it would inidcate to remove 30MB but I couldn’t because of the lack of recognition by the computer.  I’ve followed suggestions from the forum about holdihg down the center buttin, the rewind button, etc.  Other suggestions?

Same thing here.

2gig Clip-just wanted to charge it up and have frequently had to try it several times or on different computers before it would charge.

Have used some of the fixes suggested here with success in the past. This time nothing works. Just shows the “connected” screen, but battery icon is not animated.  Worse-not recognized by any of my computers Win or Mac using various cables. Unfortunately, I tried one fix suggested here and deleted everything on it, so now it has no power, no tunes, and is way to small to use as a doorstop.

 Too bad, I really got to liking the little hummer–got into music for the first time in years.

As a last resort I was thinking of opening it up and seeing if I could reset it somehow by disconnecting the batt. Can’t see any way to do it though. How the heck do they refurbish these things if there’s no way to open it without destroying it?

I don’t think I have a warranty–not sure. Got it on Woot last Dec. Lots of their items are refurb/no warranty. Anyone know where I can pick up another one for $19.95?

Warranty is one year, so you are still within warranty.  Do you have a receipt?  My warranty expired 12 days ago!!  go figure!