SanClip won't mount

My SanClip player won’t mount. it seems to be charging, but the computer does not recognize that it is there.

I have tried this on two different PCs, each of which is running Media Player above 10, and each of which has worked fine with the player in the past.

I have reset the player several times, with no effect.

I have changed the USB settings to each of the three possible settings, with every possible combination of resetting and/or unplugging and plugging back in in between. No effect.

I cannot check if a firmware update is needed, because the computer does not recognize the presence of the player on the system.

This player is less than 2 months old, and has encountered no trauma that could be reasonably considered to be a probable cause of a malfuntion.

I would appreciate any suggestions, short of squishing this thing like a bug.

You are well within the warranty period so you could contact SanDisk–use the phone or live chat, email is slow. .

Or if, for some reason, you don’t want to do that, it  could be the cord. Charging and data are separate connections, so a defective cord could be the problem.

The mini-USB connector is standard–do you have a camera or phone that has a similar cord for you to try?  Or you can buy a generic replacement online for a few bucks.

Looks like dead to me already and I hope that this wasn’t dropped. 

Check with your reseller right away and check the warranty. 

I’m having the same problem. The clip jam works ok…and when i connect it powers…but I cannot get it to mount to add anything to it.

Anyone have ideas?