Rockbox wont recognize 01.02.16 firmware

Stupid me. I followed the Rockbox instructions and updated to the latest firmware before trying to install Rockbox. Unfortunately, the Rockbox installer reports back that it doesn’t recognize the firmware and will only work with versions 01.02.09, 12, or 15. So, how do I downgrade my Clip+ back to 01.02.15 - anybody???

All the firmware versions are conveniently archived for you here, thanks to fellow Guru and extraterrestrial Marvin_Martian.

Just use the manual installation direstions. :wink: