Rhapsody Woes or Why do none of the fixes for pc to fuze recognition not function!?!

First of all, I have gone through all the threads with similar issues, and tried all of the fixes.

Firmware update? Check

Changing modes? Check. However MSC isn’t recognizing on Rhapsody, obviously because it is not an “authorized player” it’s no better than a flash drive in this mode. MTP and autodetect don’t bring up at all on my computer OR Rhapsody. Went into Device manager and it brings up the cute little exclamation mark with A Code 10 error. 

Trying to reinstall drivers? Nada. halfway thru the process, windows tells me it could not finish installing software. (with another Code 10, of course)

I have Win XP SP3 which I noticed was also in a lot of the problems most reported having…

This issue came about suddenly, no differences than normal, had been using the fuze just fine. It was authorized for Rhapsody, transfer of files worked terrifically and functioned as it should. The, one morning…nothing. Didn’t charge. Wouldn’t recognize. All thesymptoms mentioned above. Again, works fine as a storage device, and could probably use my own library and drag &drop but doesn’t solve the problem.

Please help. My $15 seems like a waste and this is why pirating seems like such an appealling option lol.

Code 10 fix:

http://kb.sandisk.com/app/answers/detail/a_id/192

Yeah…tried that one too…sorry, forgot to include that in descrip  :frowning:

Uninstall then reinstall Windows Media Player. Incorporated with Windows Media Player are the MTP drivers.