Rhapsody keeps telling me to reformat

My clip+ randomly stopped working half way thru my commute last night, telling me I needed to connect to Rhapsody. I plugged it into my computer last night for it to do it’s thing, even though I only just did it 2 weeks ago and it’s supposed to last a month. Rhapsody is saying “Your defice is not operating properly. To fix this problem, you need to reformat the device.” I have reformatted it probably about 10x now and it still won’t work. I changed it to MTP mode, uninstalled and reinstalled Rhapsody, rebooted my computer, deauthorized and reauthorized and the whole 9 yards. My freaking clip still won’t work. Rhapsody is still giving me the same error message. I’ve tried it on all 3 computers that I have authorized on my account. 


Next week I have to drive 8 hours to move to a different state and I can’t do it music-less. If I have to listen to the radio I will blow my freaking brains out…

Sounds like it’s a [C]Rhapsody issue. Do they have any forums or help pages?