Rest of World

Hi I have just brought a clip+ and I have the same problem as many others with the sound especially as I am listening to audiobooks whist doing housework etc.  I have reset factory settings, but cannot find “Rest of World” selection anywhere. I have many languages but all european or chinese. Please can you tell me what I am doing wrong.

Go to Settings/System Settings and Reset Factory Settings.

Then pick a language (I’m guessing English).

The NEXT screen is Region and that’s where you can pick Rest of  the World.