"Removable Disk" shows up in Windows 7 even when USB Flash drive isn't there

I have a new windoz 7 computer, a couple of new sandisk cruzer 16bg flash drives.

I removed the flash drives a couple of times without doing the “eject” thing. I never had a problem with your flashdrives on my xp machines. I know I was a bad boy, I just pulled the usb flash drive out.

When I go to my computer folder it shows me my hard drives and its shows 5 Devices with Removable Storage …one of which is the DVD RW Drive and 4 Removable Disk  which are or were times when I plugged in my usb flash drive. They show 0 bytes, nothing is in any of the “Removable Disk” instances and I cannot remove them.

I tried to delete, cut and I tried to eject but the Removable Disk icon stays there.

How can I get rid of these safely, I tried rebooting a couple of times, they show up even without any usb devices plugged in.

Thanks in advance


Are you sure these aren’t just all the USB ports on the new machine?

Hi Ed… thanks for the suggestion. Can’t believe I didn’t think of that…must of been too late.

This is the first windows 7 that I have and I’m not familiar with the icons and the way its set up, all my other stuff was XP’s

I feel like a real ■■■■■  because I think you might be right. it appears that there are 4 usb ports on the machine, but they always stay there whether there is something in the port or not. I thought by pulling out the flash drive it left something on the machine.

Anyway, thanks for the suggestion. I’m gonna run down to Bestbuy and see if those icons show up on some of the other computers. I put a screen shot of what stays on my machine if you’re interested.

Thanks again… Scott

unfortunately those appear to to be something left behind by the flash drive. I stopped by bestbuy and one of the geeks said they were left by Scandisk. I checked out new computers running windows 7 and none of them displayed the usb drives as I show in the above screen shot.

If you have any thoughts I would appreciate hearing



I had this same problem.  It turns out to be easy to resolve:

Open the Windows 7 “Start” Menu,  on the right shoose computer, in the new window that opens choose System Properties from the choices across the top of the window, now on the left side of the window choose Device Manager.  In Device Manager expand the “Disk Drives” entry.  You should see a listing of your hard disk drives and you’ll also see “removable disk drives” with some additional idnetifying information.  Select the offending entry and then right click and select “Uninstall” click “Okay” and the entry will be gone.  Just be sure you’re not uninstalling one of your hard disks.  That’s all there is to it.

To prevent this issue in the future always “eject” the SD drives/sticks before you remove them.

I hope this helps.

This thread is sooooooo old, however I still have the problem the OP has. The suggestion of removing it from Device Manager does NOT work for me. I do it, and as soon as I reboot Windows will search for the driver and install and the icon and the phantom drive is back listed in Devices & Printers.

I have tried everything, its really annoying. I believe it is also adding the error below in the Event Viewer. If there is anybody out there with a real solution please help.

Note: I am using Windows 7 (64)

Event 219 Kernel-PnP

The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_GENERIC-&PROD_MULTI-CARD&REV_1.00#20071114173400000&0#.

What other USB devices do you have plugged in?  A mouse, a hub, a dvd drive, etc.  Unplug them all and reboot.