Refreshing your media loop

I just bought a Clip+ 2 Gb

It worked fine until I connected it to my PC. It wasn’t identified by my PC at all and froze so I had to reset it. 

Now when I turn it on it shows boot screen (sansa and then clover logo), starts refreshing media and instantly restarts and does the same again. 

Have you tried another reset?

Several dozen times while searching for solution. 

How about, can you connect it to your computer and see if that breaks the loop?  If that doesn’t help but you can connect to your computer, I wonder if you might benefit from running an error check (chkdisk) on the player and/or, if needed, reformatting the player from your computer.

If none of the above helps (but you might want to try the reformat as a last effort, if you have content you want to keep on your player), I wonder if you might need to turn the player on and let it run down, charge it again, and then try it.

Sorry–just doing some brainstorming here, as to solutions that have worked in the past . . . .

My Sandisk sansa Clip+ happened too. I turn it on, it shows the boot screen (Sansa and then, Clover logo). Starts Refreshing your Media and it restarts and does the same again. I tried connecting to my PC and my PC is Windows 8. So I Connected, My Sansa clip+ to my PC, so It shows boot screen (sansa and the, Clover logo) and it freezes/stays at the clover logo, but it doesn’t restart, it freezes. but my PC Doesn not  recognized or does not appear on “My Computer/ This PC.” Me and my dad were solving this issue, but we Coudn’t get it. I Don’t know how to get rid of the Refreshing your media loop or a Frozen Clover logo.

We expect solutions…

SanDisk tech. support: