Refreshing Media and reset settings

I bought a Sansa Clip + 4 GB this summer, and I’ve had some problems with it but I managed to deal with them thanks to some messages on this forum. But since last week, everytime I turn my Clip on, it says “Refreshing Media”. I tried to remove the microSD card (a SanDisk ultra 32GB) to see if it wasn’t due to a loose card, however it still does it. 

I can’t download files directly on my Clip or microSD like I used to, I have to download them on my computer first and then copy the file and this wat it works. Also, the new files I add don’t appear in “Recently Added”, it’s stuck on the files I added when the device worked well, but they do appear in “Artists”.

And the settings are always reset  (shuffle off, language English even though I chose French the last time, volume,…)

If anyone could help me I’d be very grateful !

Very odd. 

It wouldn’t hurt to reinstall the firmware. Look at this thread and use the Manual method–don’t install the Updater.  Get the 1.02.18 zip file, unzip it, drag it onto the Clip driveletter.

I don’t understand how you could “download files directly on my Clip.” Are you using a subscription service (Rhapsody, audiobooks)? Or what exactly were you doing before that doesn’t work now? 

Thanks for helping me !

I managed to resolve the problem in the end (a “not enough space (…)” message appeared, my computer wouldn’t even recognize the mp3 but it worked on another computer) and now it’s okay :slight_smile: