'Refresh Database', then audiobooks stop playing

Hi.  I’m very frustrated, and hope you can help!

I’ve been happily using my SansaClip for about eight months, but then a couple weeks ago it stopped working properly.

When I turn it on, I get the message ‘Refresh Database’ with a progress bar.  It fills up in a second or two, then proceeds to the regular menu, and looks like normal.  However, after listening to my audiobook for a minute or so it just turns off.

I’ve tried doing a hard reset, reformatting, resetting, and I’ve upgraded the firmware to 01.01.30, but no luck.

Now it’s behaving even more erratically, eg not turning on immediately, turning off even before I can select music, etc.  The battery bar shows about 75% full.

Any advice?

Thanks.

Lori

Connect the player in MSC mode.  (Go to Settings> USB Mode > MSCto set the player to MSC mode )

Connect it to the computer.

Then use Windows Explorer to do a Format  (Right click on the device and select Format)

Next 

Unplug the device  and go to the settings menu,  and select “Format”

This should clean up the Clip and make it ready for you to transfer files again.

You might need to set it back to MTP mode.

Thanks, Sansafix!  I had a similar problem with my new player, and your suggestion worked like a charm.

      Paula