In order to
recover your player, please follow the instructions below:

   1. Turn the player *off* by pressing and holding the power button.
   2. On the top of the player is a Hold switch, move it to the left
      (toward the power button) so you see Orange.
   3. Press and Hold the Volume Down button (located at the bottom of
      the player) while connecting the Sansa Express to the computer,
      Continue holding it until the hardware wizard comes up.
   4. Select yes, this time only to have windows to connect to find the
      proper driver and have the software installed automatically.
   5. Wait until the Hardware wizard finishes installing the driver for
      the Player Recovery Device Class and select finish.
   6. Double click the file you downloaded earlier and run it. Follow
      all of the on-screen instructions, and when you get to the prompt
      where it asks you whether you would like to Format it, choose
      Once the Sansa Updater is done click on Finish.
   7. Disconnect the Sansa Express and move the hold switch on the top
      of the player back to the right.
   8. After the Sansa Express is done building the database, select
      language of preference.

Message Edited by needhelp2 on 03-12-2008 09:05 PM

Can anyone confirm that this also worked for them or not.  Please post.

It’s pretty hard to read through that.  If you want, I can try to convert your post to plaintext to make it easier to read.

double click what file and where do you download

what is the software you talking ofin 6th point

is that firmware 

i had done it that formatting the device and sansa is recognized but then there are two drives when i click finish on firmware window both the drives(new) are disappered 

what to do plz help me 

and SE is not at all powered on 

 I Know this sounds crazy, but after reading everything I could find and trying everything, I decided to just throw the Da** thing away. Just before I did I noticed a little slot just below the external output where you plug in speakers. For no particular reason I cut out a piece of paper and jambed in on in there then pulled it out. Viola’ it works! I have no Idea why. Can’t be that simple yet it worked. HTG

Almost wish it would go down again so I could repeat the process. Some kind of reset? Plus all my music was still there. Only logged on to pass it along. I’ll forget my password as soon as I check out good luck, let me know if it works for you.   Lowfuel… listenin to the tunes

Lowfuel, you are the man…i can’t believe this worked.  I’ve been trying to unbrick my 1gig express for at least a week, and after shoving in some heavy stock paper into the mscrosd slot, it starting to rebuild the database…


dude…this worked for me. Thanks…the paper stuff is totally out of the box ideation… :slight_smile:

But its kinda weird, because, now it shows 2 memory slots - internal and external in Settings -> Format

yeah, I its kinda a bug, some kinda a interrupt that makes the device feel that a SD card is connected.

Another thing that I noticed is it sometimes lags. I guess it can’t read any data from the paper stuffed inside…so it gets kinda confused…you know… :stuck_out_tongue:

lastly If you don’t get the paper in perfectly right, it will again not work!. So push the paper in and in and in, till it works…

The best way out, instead of this is to connect a SD card permanently. It will avoid all the issues. WIthout the SD card and paper it will not work

man…now i’ve to reload the device with all my music again. I formatted it, following the previous post.

Note to everyone who wants to buy this device: DONT BUY

everytime this device gives me some new problem…It’s stupid, that I have to survive with this device till I get a new one. This device is one of the worst mp3 players I’ve ever seen, and no one should ever buy it, unless you want to do some fiddling around with hardware and geeky stuff…