Read Only FS in Ubuntu

So I have this problem with Ubuntu8.10 Intrepid Ibex, which -except for this - works perfectly.

I mount my Sansa e280 just fine and I can read the contents just fine.  However, no matter how I much I try I can’t get the messages about the filesystem being read-only.  I’ve logged in as root and I’ve done everything I can think of and I’ve read on other forums.

So there are two possible solutions to this:  How do I fix the problem 


How do I reformat the drive?  Where do I get the firmware?  What FSes can be used?  I can back up my songs, but I want to be absolutely sure that this will work before I try it.

My HD filesystem is EXT3.

I know you Linux users are pretty determined, but surely you must know someone with one of those exceedingly rare Windows computers. Use it to backup the files and then format the Sansa. Have you tried both MSC and MTP mode? I have no idea how the two of them relate to Linux.

Hi Legoaddict

I am running 8.10 too and have no problem with me Sansa e280v2.  I upgraded from 8.04 to 8.10 and use Amarok to manage my music and my player and it all works seamlessly.  Not sure that helps you much as I am not sure why mine works and yours doesn’t.  Also I am running the latest firmware but used a windows machine to do the update.

Let me know if you want me to list any particular settings, keep trying it can work!!

Could you show your fstab?

Yeah, we’re determined :stuck_out_tongue:

I can back up just fine on Ubuntu.  It’s just a weird file system - Ubuntu reports it as vfat msdos or something similar…

How would I go about installing the firmware?  I really don’t want to take any chances.

And we have Windows mostly in my house, so access is not a problem :smileyvery-happy:

Look in Settings/Info to see what the firmware version is, 1.x or 3.x (for the two different hardware versions of the E200). Then look at the firmware install instructions in the stickies and do it from Windows. Do it manually–it doesn’t look like there will be any updates for the Sansa Updater.

Under Settings, do you see USB mode? Switch from MTP (which works with Windows Media Player and may be what’s giving you the weird file system) to MSC (which works like a flash drive). If there’s no USB mode, you have 3.x firmware that needs an update to add the switch. 

Good point you do have to be in MSC mode for Linux.  If that doesn’t work then we can look at some of the differences between my system and yours.

Although my flash drives never show up in fstab.

If it is showing up as read only, perhaps chmod can be used to change the attributes?

I’ve tried chmod to 777, and it said I couldn’t try it because it was read only (and thus I couldn’t change permissions)

I assume you used sudo?

Of course :wink:

I’m not a CLI Ninja, but I know my stuff :stuck_out_tongue:

If you boot an older version from a Live CD, such as version 7.10, does it work then?  If so, the issue must be with the newer version of Ubuntu.  You might want to poke around some of the Ubuntu forums to see if somebody on there has had issues with removable flash drives coming up as read-only.  Come to think of it, an Ubuntu forum might work for you regardless of whether the issue is with the newer version of Ubuntu or not.  Just look for general removable flash drive read-only issues rather than specifically looking for the same issue with the Sansa.

I’ve used this player with Feisty, Gutsy, and Hardy and they’ve all been fine (except for an odd thing where Rhythmbox would crash in Gutsy)…

Not to mention Dopey, Sleepy & Grumpy. :stuck_out_tongue:

Perhaps SanDisk should realize Windows is not *the only* platform out there and start accommodating the Linux community. There are many of us and we like or devices, too.