Random track skip on Rockbox

Ok please help me guys, really, because Im really going mad with this glitch which wont allow me to enjoy new rockboxed clip :confused:

  1. I got clear, Clip+ firmware 01.02.18
  2. Only 2 random test .flac tracks.
  3. I install Rockbox 3.12 with MSC usb option on
  4. Everything goes ok, I turn on clip
  5. I start playback - everytime track just skip to the next one on 0:20, 1:10 or so, randomly (with all tracks generaly, mp3 too)

I searched the web around - people tried with every rockbox version and nothing helped.


It’s not funny. Can a fact that I have OEM version of the Sansa’s product be a matter?

PLEASE help me

So are you saying the “skipping” only happens with one or the other of the 2 FLAC files you have on it? If so, I would say there’s something amiss with those files.

If not, please explain further and maybe someone can help.

I mean it happens no matter what, the 2 flacs were just for test if it is some broken file problem (because I realised clip fights with losless wma but thats normal, what I read).

It happens always with full playlist, with mp3 and flacs

EDIT: I have just discovered something that may be useful while listiening music on rockbox: it skips only on “no id3” tracks - these are .flac files. On “id3v2.3” - mp3 files its workig BUT the sound still distort around 1:03 and 3:30 of track anyway.

  • after listiening a while I got “Undefined instruction” crash error while playing mp3.

Probably want to inquire over on the Rockbox forums then. I haven’t experienced this with any of my rockboxed players, nor have I heard of it before, but it still sounds as though the problem might lie with the files themselves.

Prepare to give a lot more explicit details there than what you have provided here though, if you want a serious answer or help.  :wink:

For any type of problem, it’s important to elliminate as many variables as possible. First, load the clip with correctly tagged .mp3 files. Launch with original firmware (I haven’t used Rockbox, but gather this can be done). Then switch to Rockbox. If all is well you can proceed further with other file types, etc. But only change one thing at a time.

It’s not for nothing that differential calculus was invented!!

Thank you for the response. I will serch for help with that Rockbox issue on their forum.

Just one more thing, annother matter is what I experienced today - the battery was almost full and suddenly went off empty. Also, one time the player just reset after playing a track, back to the moment when I turned it on. It’s unusual behavior, Im wondering if it’s because of OEM version? :neutral_face:

It plays everything ok on basic firmware newest version, flacs, mp3. But battery problem is not funny so I think will I have to raise a complaint.

******* PROLEM SOLVED *********

Just want to write you guys, if anybody will face that problem:
Most probably it is an hardware issue. I have raised a complaint to my vendor and got this clip+ replaced. (It also had resets and freezes on original firmware).
Its all OK on that new one. Still OEM.

I had very similar track-skp problems, and also random noises varying from whiteish to sounding like a skidding needle on a record on one channel at a time for a fraction of a second. I was running Rockbox 3.14 stable release on a Sansa Clip+ purchased in late 2017.

This thread on the Rockbox forum starts on another issue, but starting with reply #11 it discusses my problem: http://forums.rockbox.org/index.php/topic,52044.0.html. The developer Saratoga suggested that a new battery saving adjustment might be at fault, and provided an older Version 1015088, which appears to have solved the problem. I’ve run for 2 weeks without noticing a glitch. Since the glitches seemed random I can’t be totally sure of success.