quickly deleting files on my Clip+ using my iMac

hi, i’ve done some searches but haven’t found appropriate answers (unless i missed it).

i’m using my iMac to load and delete songs on my Clip + (4Gb and an 8gb card).

now, here’s the trouble, if i drag a whole album folder from my harddrive to my Clip Plus, the album folder shows up on the Clip Plus. if i drag an artist, that artist folder name shows up and all the albums.

but if i drag just individual songs (let’s say i just want 4 songs off an album) only the song titles show up as files.

now, when i want to delete songs i can’t select either an artist or an album, i have to search song by song to delete the files. it’s doable but a pain.

any shortcuts? in real terms, let’s say i add Hells Bells, Shoot To Thrill and Have A Drink On Me one week but the next i want to delete all my Back In Black songs to make room for a new album. i have to wade through gigs of songs to find each one and erase them as opposed to just picking the album Back In Black and deleting all 4 songs at once.

any help? anyone create some kind of Mac interface yet?

thanks. sorry if this sound confusing. i’m just looking for a speedy way to select and delete songs by artists or album when i only have individual files that are amongst thousands of other song files.

I don’t know if this will help, but Internet freeware Kopymac is said to work nicely in transferring files from a Mac. 

hi, it tried it out before as i had an issue with a counterfeit card.

i don’t think KopyMac organizes files according to artist, album – what i’m looking for. 

it is, i think, just a “cleaner” way to transfer files, as i’ve heard doing so with a mac adds some extra files to the memory for some reason.

but thanks.

Have you tried this?


It runs OK on my Mac and does give a better interface but I don’t know if it will do what you are after.

KopyMac isn’t the answer as you say.

I don’t use the mp3 tags information at all to organise my files as I just use the normal Mac file structure with folders etc so haven’t tried XNJB as I don’t actually need it.

hi, thanks for the above suggestion but the link is broken: it says Object Not Found! or something like that.

if you could try again, or give me the name of the program, that would be great! thanks.

edit: i hit another link on that page and it sent me to wentnet so thanks, i’ll explore that.