Progress Bar error?


I’ve noticed in a few instances, when listening to MP3s, that  the progress bar will get to full when the track isn’t complete, and yet the elapsed time keeps increasing.

For example, I was listening to a lecture 1h:04m:15s in length, filesize 27MB, and after about 35 minutes in, I noticed the progress bar was full, yet it had about 1/2 hour to go…

I have a Clip+ with firmware 01.02.13 installed, and the files are on a SanDisk 8GB MicroSD card.

Anyone know whether this is a known problem problem with the MP3 file format, rather than the player? That said, I never noticed it happening on my old Clip original.

Any thoughts greatly received!

I would expect there’s an issue with that MP3 file before expecting issues with the player itself.

Did you try the MP3 on your PC in various players? 

It could be it has a broken header or some other damage. I have seen this with certain VBR MP3’s, or MP3’s that had been merged incorrectly.

Thanks so much!

I’ll investigate that in the manner you suggest.

I’ve been having the same issue with the latest audiobook I listened to.  And the worst part of the problem is that if you pause/power down (my method of ‘bookmarking’), when you resume listening, it will automatically skip to the next file.  The file was originally encoded VBR, 22 kHz, mono.   There seemed to be something strange in the encoding: some players would should the correct lenght (1h 17min 3 sec) and some would show half that (39 minutes) including the Sansa Clip+ I use.  I tried several methods of re-encoding the file, some produced files that showed file lengths of days.  The only ones that worked seemed to be those that exported the file to a .wav and then re-encoded the whole file.  The worst of the conversion programs was the Windows Audio Converter, and the easiest to use was Audacity. 

In general I think I’ll avoid using VBR files for my audiobooks.  The few megabytes saved aren’t worth issues with the duration.  I’m not even sure what exactly caused the issue since it was not unique to the Sansa Clip+. 

If Sansa developers are reading this thread, I can provide a copy of the file that caused the issues for a more extensive analysis.