Problems with Win7 64-bit

@machque wrote:

Sansa Clip Zip vs. Windows 7 with CA Security Suite anti virus.   Tried the uninstall suggestion, no help.  Windows & says no driver found no driver installed.  When I they to update firmware noting happens beside the area above the work screen (Top tool bar) flashes.  Still get Sansa Clip Zip with yellow triangle in device manager.  Clip Zip works fine with Linux or XP machines so it’s not the device itself, tech support had me replace my original Clip Zip.

Your windows install is somehow messed up. Try MSC mode if you haven’t. If that doesn’t work, I would start troubleshooting your chipset drivers, etc.

@neutron_bob wrote:

The problem is on the PC with Windows 7 and WiMP12.  (Media Player 12 is standard with Win 7).

 

You can fix  the MTP  connection as follows:

 

Turn on the Clip and go to Settings > System Settings > USB Mode and manually select MTP.   This will hold the device in MTP mode.

 

Plug in your device, and open the Device Manager.  Click on the Sansa under Portable Device and select Properties, then select uninstall  while connected.  I know this sounds counterintuitive, but what you are doing by this operation is telling the PC to clear the registry entry for the recognized device.

 

Unplug the Sansa, and wait about 30 seconds for the operation to complete (or to be sure, restart the PC, but you shouldn’t have to with Windows 7).

 

Now plug in the Sansa once again, in a few seconds, it will show “connected” on its display, and you will then see a popup stating “new device found, MTP Device”.  This should do the trick.  Once the PC registers the device, MTP should now work.

 

The biggest advantage to using MTP is that playlists  can be built using Windows Explorer (via a right click on your music), or with Windows Media Player, and playlists are possible using both the internal and external memory, as pla  format playlists.

 

The downside of the MSC / MTP communications difference with the Clip or Clip Zip is that the USB controller in the Sansa onlyworks with one mode at a time,so music transferred in one mode is “invisible” to the PC while in the other mode, so you need to have all of your music transferred in one mode.  The Fuze+  has a different controller that allows both transfers to be accessed simultaneously.

 

Bob  :wink:

I’m having a similar problem; I use Rhapsody and the program won’t recongnize my Clip as a MTP device, and therefore won’t let me transfer subscription music to it.  I’ve had no trouble with this Clip on a previous Win7 machine and a Vista machine before that.  I’ve tried your solution, but when I reconnect the Clip in MTP mode, the PC says it can’t find the driver.  If I connect it in MSC mode, the PC will find the driver and install it, but then can’t see it as an MTP device.

Any suggestions?