Problem With Album Art

Please see my other thread, the mystery deepens …

I did read your post and you have an interesting find there. The difference with my issue is that all the pictures (album art) is being made in the same place at the same time but they get different results in the Clip Sport. I’m getting ready to make another set of pictures and giving it another try. Is there a suggested picture file type I should use?

1 Like

@riptrack59 wrote:

Is there a suggested picture file type I should use?

JPG. Plain, old, white-bread, run-of-the-mill variety .jpg. NO progressive, no .bmp, no .png, no .gif, etc.

I had similar problems when making album art for my mp3s on the Clip Zip.  I found that if I follow three rules problem solved.

1: I make sure that the picture is square (which it sounds like you are doing)

2: I like to use JPEG (though I’ve noticed other formates seem to work fine as well, but I just like to keep a standard)

3: The file has to be under 20kb, which it looks like you are a bit over.  Even if the pictures are all the same “size” (480x480 in your case), if you have a higher resolution it may get over that 20kb threshold, and therefore won’t show up.

This works for my Zip, and so far seems ok with my Sport too, but I’ve not played with it as much.  May be a good place to start though.

They don’t need to be below 20kB in size.

I’ve got examples that work fine, and show as 82x82 images (on Clip Sport display), for a file as large as 83.6kB. I just scaled the images down (using ImageMagick v6.7) to 192x192 pixels, and file sizes shrunk (but not to below 20kB).

Note: Previously, I used the same technique for the Sansa Clip Zip, but scaled down to 128x128. When I saw the Clip Sport was available (with  128x128 OLED display, instead of 96x96 ), I changed to 192x192 , which still works fine on the Sansa Clip Zip.

Well, I resized all the pictures to 192 by 192 and none of them work. I think I wasted enough time on this…I can only assume that there is a problem with my Clip Sport. From this point on I’ll load them up without pictures.

1 Like

Try these out.  I kept your dimensions and just resaved them with a lower resolution using paint.net so that they were under 20kb per pic

sansa pic help

I am having the same problems.  I have tried all your technique above to no avail.  Still no artwork showing at all…  Any updates on this now?

Here is my image file.

Any help would be greatly appreciated!

I have downloaded your image file on a Clip Sport and the artwork is showing beautifully. The only thing you should need to do is to rename the file to folder.jpg and copy it to the desired Album folder on the player.

1 Like

Thank you so much for the reply.  I am glad to hear it worked for you.

Based upon your instructions, I think I may be misunderstanding how the album artwork files work here.

In the past, I simply had the artwork embedded in the mp3 file and it would show in the player.  No need to place anything in an album art folder.  This worked flawlessly on the Sansa Clip Zip.  I’ve tested a file with this artwork and it plays fine and shows the embedded artwork not only on the Sans Clip Zop, but also in iTunes, Windows Media Player, Vox, VLC, player and all my Android music apps.  Again, no need for a separate folder, just that mp3 file.

Here is the file:  https://dl.dropboxusercontent.com/u/542737/012-Yusuf-101_-_Abdullah_Basfar.mp3 (its only 750 KB)

Does the Clip Sport work differently than everyone else?  What do you think I need to do to get it working?  I may need step by step instructions.

Thanks so much for your help.

Embedded art is an alternative and works too. What software have you used to embed the artwork in the mp3-file you linked to? That one didn’t work “out of the box” but when i embedded the same artwork with VLC to your file it shows up in the Clip Sport just as it should.

Here is step by step instructions for Windows Media player:

http://kb.sandisk.com/app/answers/detail/a_id/221/kw/album%20art/session/L3RpbWUvMTQyMjUzMzkzMy9zaWQvN3NuY0NGZG0%3D

Some general information (using MP3Tag as editor):

http://tips4pc.com/computer-gadgets/five-reasons-your-mp3-player-doesnt-show-your-album-art.htm

I will investigate this further but it would great to know what software you have used to embed the artwork.

1 Like

Hi,

Thanks so much for taking the time to look at this and reply so quickly.  I guess my thread notifcations aren’t working because I never  got a notice that anyone replied.

Anyway, if you are still able to pick up where we left off.  I have been using iTunes (12.0.1.2.6).  It usually embeds the artwork no problem when you add artwork manually (not auto-downloaded from the iTunes store), but I also used the Doug’s Apple scriptto embed the artwork as an extra step.  It has always worked fine in the past with all the Sansa stuff.  I’m not sure what is different now.

Thanks for any more help you can offer!

Your file https://dl.dropboxusercontent.com/u/542737/012-Yusuf-101_-_Abdullah_Basfar.mp3 uses the tag format ID3v2.2 which the Clip Sport doesn’t seem to be fully compatible with. The preferred tag format with this player is ID3v2.3 although ID3v2.4 works well too. You can convert the tag format with iTunes: https://discussions.apple.com/thread/4555351

Choose version 2.3 in the droplist. It’s possible to select multiple tracks at once if you want to speed up the process.

I have downloaded your track, imported it into iTunes 12 , converted the tag version to ID3v2.3 and copied it to the Sport and it seems to work OK. To verify the ID3 Tag version for a track select “Get Info” in the menu.

1 Like

BAM!  That worked!  I used 2.3.  I thought it might be something about the ID3 tag version, but I could not find any documentation saying what the ClipSport prefered.

Thanks so much for your help.  This has officially been solved!

I thought I give it one more try to get my album art to show up on the Clip Sport. I started working on a new music library in latest version of Itunes. I made a 192 by 192 picture for each year of the 1970’s. I added the songs for 1970, and then added the 1970 album art to the songs. I made sure the ID3 Tag was set to 2.3 for all MP3 songs. I added the songs to the Clip Sport and all the picture showed! I’m a happy boy.

The I did the same process for the 1971 songs. Made a 192 by 192 album art and added them to the songs, set the ID3 tags and added them to the Clip Sport and…none of them work. Why? I have no idea.

My Album Art

Above is a link to my albume art pictures. Can somebody please tell me why the 1970 picture shows up perfect on the Clip Sport and the 1971 picture doesent show at all?

From what I can see the album art for 70 and 71 are identical in every way with the exception of color. I have not check beyond 71 to see if the other work yet. I need some help figuring out this “head scratcher” problem.

I have looked into this and oddly enough it seems to be the embedded EXIF metadata in your image files that confuses the Clip Sport. This data is differently formatted in the file that works (1970.jpg) compared to the ones that doesn’t. The images seems to be created with PaintShop Pro X6 and that software is capable of editing EXIF metadata directly. As a first step though I would like you to remove the data all together on one file and confirm that it works.

The easiest way is to upload the image file 1971.jpg to http://www.verexif.com/en

Select “Remove Exif” and save the new file. Then try to use that image file with the Clip Sport.

If it works, update (or simply delete) the EXIF metadata within your image files with PaintShop Pro : https://www.youtube.com/watch?v=OqN9Cluc1jI

1 Like

Thanks for looking into this. When I have more time I’ll see if what you suggested works. Also…Would it help if I re-saved the picture files in Gimp?

Ok, that didn’t take as long as I thought…I ran 1971 and 1972 throught the nifty program you showed me. 1971 now works perfect, but 1972 shows up but it’s a much smaller picture. How can two pictures of the same size show up differently on the screen?

One last added note- It appears that all music files that are mpeg have normal sized album art. All music files that are AAC files show a smaller picture for some reason. Any fix for this?

@riptrack59 wrote:

Would it help if I re-saved the picture files in Gimp?

Yes, although you will loose some quality for every re-save of a jpeg-file.

In Gimp, select File - Export As… in menu.

Give the new file a name.

In the dialog “Export Image as JPEG” expand “Advanced options”.

Uncheck ”Save EXIF data” and (optionally) check “Use quality settings from original image”.

Export the file.

1 Like