Problem updating firmware

Hi! Trying to get my M230 working with Vista;

     I got the puter to see the device by renaming the infcache1 file.

     I was able to transfer music to the device, and play it.

     When I open windows explorer, I could see the music that I just transferred, but none of the music that was on the device pre-Vista.

     When I changed my USB setting to “auto detect” I could see the music that was on pre-vista, but not the music that was just transferred.

     I attempted a firmware update (which failed) hoping that would straighten it out, but now when I connect my Sansa in MSC mode, I get the following error:

           "Exception processing message 0xc0000013 parameters 0x75f7023c 0x84061e2c 0x75f7023c 0x75f7023c.

     I formatted the device in auto detect mode, which seems to have worked, but when I try to update the firmware now I have to be in msc mode, which produces the aforemention error.

Don’t know where to go from here. I can use the device as is, but only in auto detect, which precludes any firmware updates.

My apologies if a double post shows up. I hit the “tab” key, and it did something unexpected.

Addendum to OP.

The error message refers to a conflict in the assigned drive letter. I found that when I plug the device into my computer in auto detect mode, the device is called drive “J”, and everything works. When I plug the device into my computer in msc mode, it is called drive “H”, and the error occurs. I tried to go into disk manager and reassign the drive letter, but to what? “J” is not given as an option to me. I gave it a random assignment of “M”, and still have errors.

Looking for suggestions.