Problem occurred obtaining the device's certificate

New to the clip.  I have been trying to download an album of songs to the clip that I PURCHASED from Rhapsody, that downloaded to my computer in RAX file format.

Whenever I drag a RAX formated song to the Clip - I get the error  “Problem occurred obtaining the device’s certificate”.

After about 8 hours of trying to fix the problem, I think I am ready to give up while I still have my sanity.  WMP will not recognize the songs format. 

I was able to load another song I purchased in MP3 format - so I believe the problem must be with the RAX format.  I tried using Rhapsody to covert the fromat to WMA by re-downloading, but that has not worked either.

Any words of wisdom?



Update your RHapsody software to the latest released version.

Next under Device options,  Remove any “cached” versions of the RAX files,  what happens is Rhapsody is resending a bad converted file. 

Checked - I have the latest version and I cleared the cache.

Still have the same problem.

under the settings menu on the clip go to format. once selected you will be prompted to confirm. this will erase all the music so make sure you have a backup. once format is complete go back to the settings menu and reset factory settings just for good measure but the format should fix the issue. then connect the clip back and you should be good to go. let us know if it works. 

The Sansa Clip is a RhapPFS device , and it won’t play RAX files!  The rax format is for the Sansa Rhapsody (e200R) only.

First, how about a few basic operations, and hopefully, a happy singing Clip!

Connect your Clip in MTP or “auto detect” USB mode.  Open the Rhapsody 4 client, and your Clip chould show up in the sources pane as Sansa Clip 2GB caps and smalls, no drive letter.  You may have a different capacity than this example.

If the Clip is showing in all capital letters, with a drive letter assigned, it’s in MSC mode, and Rhapsody cannot transfer WMDRM files in this mode.

Right click on the Sansa to select “Authorize”, and look in the lower right corner of the main window pane for “Licensed until 07/17/2008” or similar, indicating the device is licensed.

Under device options, select “let Rhapsody decide the format”, or manually select wma for your Clip transfers.  It sounds like the client is working with RAX format currently.

Bob  :smileyvery-happy:

Thanks for your help.  Problems resolved.  I formatted the device and reinstalled Rhapsody.

That seems to have resolved the issues.