Problem: Fuze suddenly "froze" in on position. No music. Not recognized by pc.

I was listening to my fuze when it suddenly stopped playing music.

The screen is black the wheel is lit but unresponsive. 

I have tried to turn it off but it will not let me. 

I attempted to connect it to a pc but the computer did not recognize it and the device did not respond in any way. 

Currently I am content to allow it to drain out with the hopes of recharging it.

The device was a Christmas gift this year.   It is new with no previous owner.

Should I try and return it or wait it out?

–NeA

Have you tried resetting it?  To do that, hold the power switch in the off position for I think 10 or 20 seconds.

Hold the button up longer than you think you need to–20 or 30 seconds. That should shut it off. Turn it on again and see what happens.

Since it’s new, you could also just exchange it. It’s not supposed to behave like that out of the box. 

The other possibility is that you put on some files it really, really didn’t like–did you put on anything from shady sources? Anything with a lot of unusual or foreign characters in the filename or ID3 tags? Because those will trip it up, but it would have to be pretty severe.

10 seconds…

That’s a good tip, I shortened all my file names too.

So it’s working again? 

Shorter filenames never hurt, but there’s other information that the Sansa also has to digest: ID3 tags. And it’s a little picky.

You can read about tags here.