Possibly multiple issues - "One USB...Device Malfunctioned" message balloon in Windows...

I have had my Fuze for close to a year, it’s the 2 GB version. My computer is running Windows XP 64-bit, up-to-date Windows Media Player. My Fuze has version V01.01.11A installed.

The problem that I’m having started Thursday afternoon (two days ago). I charged/downloaded music on Wednesday, and didn’t have any issues Wednesday afternoon/Thursday morning. Thursday afternoon when I turned the device on the green “Refreshing” message window came up on the device and the time was not right. I did a soft reset, when it came back on it had the “Refreshing” message window again. It took several minutes for that message to go away, when it did go away the battery was completely dead. I had only used the device for 2 hours after it had changed on Wednesday and had a full battery. 

Thursday afternoon when I plugged the device into the computer to recharge I got the “One USB…Device Malfunctioned” message balloon in Windows. After a couple minutes of being plugged in the computer recognizes the device. I have tried to download/install updates for the Fuze through Sansa Updater and manually through the link from the forum and haven’t been able to get updates to install. Sansa Updater gives me a message that the updates were not able to download properly, try again later. When I disconnect the device from the comptuer it comes up with the "Disconnected"message and freezes on that screen. 

I have tried reformatting the device both through the settings menu on the device itself and through “My Computer” in Windows. I wasn’t able to format the device from the comptuer, I kept getting a message saying “Unable to format Device”. After formatting the device from the settings menu and plugging it back into the comptuer, I could still find a few songs. I also tried resetting it to factory settings. I have changed the USB setting on the device to “MSC” (to install updates manually). When I try to install the updates manually I get a message along the lines of “you don’t have permission to…” something. 

I’m not really sure what else to try. I don’t understand why this thing worked fine Thursday morning and 6 hours later is going haywire. 

Any suggestions?

This sounds like something you should call SanDisk about, 1-866-SANDISK in the USA. Your warranty runs out after a year, so especially if it’s getting close, get some action.

My strictly amateur guess is that it’s a hardware problem–like the internal memory or some connector is going bad. That would explain Windows not being able to format, and the unit’s format not taking effect.

For the permissions thing with Windows, make sure you are logged in as the Administrator on your computer.

There’s no reason to use the Updater.  Download the firmware, unzip it, and just put the .bin file into the Sansa Fuze drive.  But if it can’t get written onto the Fuze memory–which is what I suspect–it’s going to have to go back to SanDisk. 

Message Edited by Black-Rectangle on 12-12-2009 10:32 AM

Yeah, I was worried it was something that I wasn’t going to be able to fix on my own since I’ve tried everything I can find to try and nothing’s helping. Especially after I formatted from the device, then went into it from Windows and was able to find songs still. I had to search for them a little, but they’re still there. I am logged in as the Adminsitrator on this computer, I’m the only user so there’s no reason to have another non-Administrator user option. My husband has the same model Sansa that I have, I bought them both at the same - his is having issues with the wheel thing. I guess I might as well ask about both of them when I call.

 Thanks for the help!